XMP encodage des caracteres

Questions générales en Français

Moderators: XnTriq, helmut, xnview

GJJOU
Posts: 3
Joined: Tue Jun 20, 2023 9:52 am

XMP encodage des caracteres

Post by GJJOU »

Bonjour,
je viens d'installer XnviewMP 1.4.5 sous Windows7 64 bits
Je note que l'écriture des tags XMP avec des lettres accentuées est correcte si je le fais photo par photo (JPEG).
En revanche, en utilisant "écrire dans les fichiers" avec plusieurs photos sélectionnées semble convertir les lettres accentuées en les décomposant en codage UTF8, codage qui s'emballent si je réécris à nouveau les tags .
EXEMPLE :
texte introduit (dans la légende):
test des accents
à
é
par exemple

texte affiché à la relecture :
test des accents
Ã
é
par exemple

texte réécrit suite à modification (ajout d'un espace à la fin) :
test des accents
Ã
é
par exemple

Ma config indique
(Métadonnées/encodage):
IPTC => locale
"utiliser l'UTF8 pour écrire l'IPTC" est coché
(Métadonnées/companion):
JPEG => OUI
"mise à jour ou création du sidecar" n'est pas coché

note : locale == français (dans panneau de configuration Windows "région et langue"

Ai-je la berlue ?
Y a t-il une façon de procéder ?

Cordialement
User avatar
xnview
Author of XnView
Posts: 43723
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: XMP encodage des caracteres

Post by xnview »

oui c'est un bug connu
Pierre.
GJJOU
Posts: 3
Joined: Tue Jun 20, 2023 9:52 am

Re: XMP encodage des caracteres

Post by GJJOU »

Merci
Dois-je revenir sur une version antérieure en attendant ? ou utiliser Digikam :?
Cordialement
User avatar
xnview
Author of XnView
Posts: 43723
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: XMP encodage des caracteres

Post by xnview »

GJJOU wrote: Tue Jun 20, 2023 11:54 am Dois-je revenir sur une version antérieure en attendant ? ou utiliser Digikam :?
Oui vous avez la 1.4.4 ou sinon la 1.5.0 beta
Pierre.
GJJOU
Posts: 3
Joined: Tue Jun 20, 2023 9:52 am

Re: XMP encodage des caracteres

Post by GJJOU »

Après test de la 1.4.4, la 1.4.3 me parait plus indiquée