liblibraw.so.1 not found when I try to execute XnView

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, helmut, xnview

zoliky
Posts: 5
Joined: Sat Oct 02, 2021 1:50 pm

liblibraw.so.1 not found when I try to execute XnView

Post by zoliky »

I downloaded and extracted the 64-bit TGZ file on Debian 12, and when I try to run XnView, I encounter this error:
./XnView: error while loading shared libraries: liblibraw.so.1: cannot open shared object file: No such file or directory
I have no idea which package I should install to provide this library. I would appreciate any suggestions. Thank you.
User avatar
xnview
Author of XnView
Posts: 43173
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: liblibraw.so.1 not found when I try to execute XnView

Post by xnview »

you start ./XnView or ./xnview.sh
Pierre.
zoliky
Posts: 5
Joined: Sat Oct 02, 2021 1:50 pm

Re: liblibraw.so.1 not found when I try to execute XnView

Post by zoliky »

Yes, but I get that error when starting it.
User avatar
xnview
Author of XnView
Posts: 43173
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: liblibraw.so.1 not found when I try to execute XnView

Post by xnview »

zoliky wrote: Mon Oct 02, 2023 1:17 pm Yes, but I get that error when starting it.
but which command do you use?
Pierre.
zoliky
Posts: 5
Joined: Sat Oct 02, 2021 1:50 pm

Re: liblibraw.so.1 not found when I try to execute XnView

Post by zoliky »

Ok, now I see. It works when I use "xnview.sh". It only had errors with ./XnView. Thank you!