[Résolu] Add-On Face Tag ne fonctionne pas

Questions générales en Français

Moderators: XnTriq, helmut, xnview

Animor
Posts: 5
Joined: Sun Aug 13, 2023 1:18 pm

[Résolu] Add-On Face Tag ne fonctionne pas

Post by Animor »

Bonjour à tous.

Je viens d'installer XnView MP Winx64 v1.5.3 et téléchargé son add-on Face Tag :
https://www.xnview.com/wiki/index.php?t ... _Face_tags

Cependant, celui-ci ne fonctionne pas.
Je l'ai dézippé et déplacer dans le dossier d'installation à C:\XnViewMP\AddOn\FaceTag mais une fois dans XnView il n'apparait pas du tout dans l'onglet Outils.

Quelqu'un aurait une idée ?
Merci à vous.
You do not have the required permissions to view the files attached to this post.
Last edited by Animor on Fri Aug 25, 2023 12:28 pm, edited 1 time in total.
User avatar
michel038
XnThusiast
Posts: 1313
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: Add-On Face Tag ne fonctionne pas

Post by michel038 »

Dans les versions récentes (?) le menu a été déplacé dans "Métadonnées".

-En mode navigateur, sélectionner une ou plusieurs images, " Métadonnées > Etiquette de visage "
Dans la fenêtre il y a un bouton "Recherche des visages" et un seuil en haut à gauche, un autre bouton en haut à droite , je n'ai pas le détail des manips.

La reconnaissance de visages automatique n'est pas disponible, il faut nommer chaque personne, et provoquer l'écriture en métadonnées xmp.
Pour dégrossir la reconnaissance de personnes sur des dizaines de milliers de photos, j'ai utilisé d'abord Picasa...

-En mode vue, il y a une option "Vue > Afficher les régions des personnes"

EDIT Janvier 2024
depuis la version 1.6.3 , il faut utiliser le menu "Outils>Plugins" pour installer le plugin facetag
mots clés pour rechercher dans ce forum: plugin face tag facetag addon add-on
Last edited by michel038 on Wed Jan 10, 2024 6:47 pm, edited 1 time in total.
Animor
Posts: 5
Joined: Sun Aug 13, 2023 1:18 pm

Re: Add-On Face Tag ne fonctionne pas

Post by Animor »

Ah super, en effet j'ai trouvé.
Merci beaucoup !
Animor
Posts: 5
Joined: Sun Aug 13, 2023 1:18 pm

Re: Add-On Face Tag ne fonctionne pas

Post by Animor »

Par contre, à moins que je n'ai encore rien compris, il n'est pas possible trier les photos par personnes ? Dans mon filtre de catégories la liste de personnes reste vide... :/
User avatar
michel038
XnThusiast
Posts: 1313
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: Add-On Face Tag ne fonctionne pas

Post by michel038 »

Dans Paramètres > Métadonnées, il faut cocher la dernière option "Importer les champs XMP face".
Et peut-être aussi la première option du même écran "Importer les mots clés ..." : c'est à tester, pour voir si c'est indispensable.
A partir de là, les photos nouvellement marquées de tags de visages devraient entrer dans le catalogue et être visibles dans le filtre catégories.

Puis il faut faire la mise à jour xmp vers catalogue pour les photos qui contenaient déjà des tags de personnes.
- sélectionner les images et cliquer dans "Afficher > Mise à jour du catalogue à partir des fichiers"
( ça n'a pas toujours parfaitement marché dans les anciennes versions ... je ne sais plus où on en est. J'avais dû enlever puis remettre le dossier d'images dans le tableau Paramètres > Catalogue, et l'option Importer les mots clés ... risque d'être nécessaire aussi)

Je n'ai pas pratiqué depuis longtemps, et je ne peux pas trop faire de tests avant un mois.
Animor
Posts: 5
Joined: Sun Aug 13, 2023 1:18 pm

Re: Add-On Face Tag ne fonctionne pas

Post by Animor »

Encore merci à toi pour ta réponse.
Malheureusement ça ne fonctionne toujours pas...
(Je vais tenter une réinstallation)
User avatar
michel038
XnThusiast
Posts: 1313
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: Add-On Face Tag ne fonctionne pas

Post by michel038 »

Je suis en train de faire des tests avec XnViewMP 1.5.0

- Ajout de 2 nouvelles personnes avec Face tag
- les métadonnées XMP sont bien écrites dans les photos
- le catalogue n'est pas mis à jour, les nouvelles personnes n'apparaissent pas dans le filtre des catégories.

Avec "Mise à jour du catalogue avec les fichiers" et avec suppression/importation du dossier dans Paramètres>Catalogue ... non plus.

... j'ai essayé 1.5.0 , ça marchait

Bon , après de multiples tests, et combinaisons d'options, ça remarche dans tous les cas :shock: :?:

La manip la plus solide : suppression/importation du dossier dans Paramètres>Catalogue , en ayant coché pratiquement toutes les options dans Paramètres métadonnées.
Last edited by michel038 on Wed Aug 16, 2023 1:34 pm, edited 1 time in total.
User avatar
michel038
XnThusiast
Posts: 1313
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: Add-On Face Tag ne fonctionne pas

Post by michel038 »

Bon, j'ai trouvé.
"Mise à jour du catalogue avec les fichiers" ou suppression/importation du dossier dans Paramètres>Catalogue
Les deux méthodes fonctionnent

Il suffit simplement que l'option Paramètres>Métadonnées "Importer les mots clés ...dans le catalogue" soit cochée
C'est pas tellement intuitif :(
et probablement "importer les champs xmp face" aussi, mais cette option aurait dû se suffire à elle même ...

Et du coup, en utilisant le plugin, le catalogue se met à jour automatiquement aussi.
Si ça marche, vous pouvez ajouter [resolu] dans le titre du premier post
------------

Notez que cette option d'importation des mots clés est utile si vous essayez (quelle folie !) d'entrer des mots clés avec la fenêtre "Editer IPTC".
L'écriture en IPTC + l'importation dans le catalogue , ça met à jour le catalogue et les catégories à la volée.
C'est le même mécanisme qui est à l’œuvre avec le plugin face tag.
L'ennui c'est que lorsqu'on parcourt des dossiers autres (par exemple téléchargements , ou le cache du navigateur), on importe un tas de mots clés étrangers à notre environnement. Il faut penser à exclure ces dossiers au préalable dans Paramètres>Catalogue>Exclusion/Inclusion
Last edited by michel038 on Sat Sep 02, 2023 5:15 pm, edited 1 time in total.
Animor
Posts: 5
Joined: Sun Aug 13, 2023 1:18 pm

Re: Add-On Face Tag ne fonctionne pas

Post by Animor »

Bonjour,

Encore merci Michel pour ton aide !

J'avais laissé un peu tombé à vrai dire, car depuis la réinstallation de Xnview, quand je cliquais sur Métadonnées > Étiquettes de visage, le logiciel plantait... (je l'avais installé dans un dossier dont le nom comportait un "é", ça devait pas lui plaire)

Je viens de re-réinstaller autre part.

L'option Paramètres > Métadonnées "Importer les mots clés XMP dans le catalogue" est cochée par défaut.
J'avais aussi bien coché "Importer les champs XMP Face".

Tu avais soumis l'idée, je viens de tout coché dans Paramètres > Métadonnées et étrangement, cela semble fonctionner !
(Pour le moment :wink: )

Merci à toi !