"Save as" always selects bitmap format

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, helmut, xnview

Konzertheld
Posts: 43
Joined: Sun Feb 27, 2011 9:43 pm

"Save as" always selects bitmap format

Post by Konzertheld »

Hi there,

my "save as" dialogue always pre-selects the bitmap (bmp) format. I don't even have any bitmap images. The option "use same file format" has no effect. I am on XnView 1.4.4 and I use the Flatpak version. What could be the reason? Are there more options that influence the file format? Or did I find a bug?

Cheers,
Christian
User avatar
xnview
Author of XnView
Posts: 43897
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: "Save as" always selects bitmap format

Post by xnview »

what is source format?
Pierre.
Konzertheld
Posts: 43
Joined: Sun Feb 27, 2011 9:43 pm

Re: "Save as" always selects bitmap format

Post by Konzertheld »

It happens for jpg and png images. I rarely use any other formats.
User avatar
xnview
Author of XnView
Posts: 43897
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: "Save as" always selects bitmap format

Post by xnview »

could you send me your xnview.ini?
Pierre.
User avatar
xnview
Author of XnView
Posts: 43897
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: "Save as" always selects bitmap format

Post by xnview »

i've tried your xnview.ini.
I open XnView, click on a jpg and open it. 'Save as' and 'jpeg file' is selected.
Pierre.
Konzertheld
Posts: 43
Joined: Sun Feb 27, 2011 9:43 pm

Re: "Save as" always selects bitmap format

Post by Konzertheld »

Interesting. I now tried the AUR version instead of the Flatpak version, using the same xnview.ini, and the problem immediately disappeared. XnView does have full system access though, so the usual permission problems with Flatpak should not appear. Do you have any idea what could make the difference? Just a faulty build on Flatpak?