Change timestamp tool not working with tif files

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
KLE-France
Posts: 10
Joined: Mon Jan 14, 2019 3:00 pm

Change timestamp tool not working with tif files

Post by KLE-France » Thu Oct 03, 2019 3:32 pm

Hi to all,

!!See edit below!!

The basics: Windows 10 home, 64 bit; XnView MP Windows, Version 0.93 64 bits (Jan 31 2019).

And on to the issue:

I have a number of pictures that lost their from-camera exif data when they passed through post-processing programs.

The primary datum that is of interest to me is "Date taken".

Of course, XnView MP has its "Change Timestamp" tool, which, I can use to add an approximative date based on neighboring images.

The change Timestamp tool works perfectly for JPEG images, but I systematically get an error message: "Problem - An error occurred in updating process!", when I try to use it on TIF files.

Looks like this:
TimestampTifProblem.jpg
What am I doing wrong?

Thanks in advance for you help and keep up the good work!
KLE

EDIT: It turns out that this does not happen with all tifs that have lost their exif data. What exactly the defining factor is, I have not yet figured out. BUT, I did notice that if I use ExifToolGUI (http://u88.n24.queensu.ca/~bogdan/) to remove metadata from a tif image, I can then go back to XNView MP and successfully use the Change Timestamp to put in an approximative date taken.

For what it's worth, after the metadata removal process by ExifToolGUI, this latter gives a message saying that it fixed a minor error of exif data not being in order. Might that have something to do with it?

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Change timestamp tool not working with tif files

Post by xnview » Fri Oct 04, 2019 9:14 am

could you send me a tif file with problem?
Pierre.

KLE-France
Posts: 10
Joined: Mon Jan 14, 2019 3:00 pm

Re: Change timestamp tool not working with tif files

Post by KLE-France » Fri Oct 04, 2019 5:33 pm

Hé bien, mince, mince et triple mince !

I've already repaired all of the files that had the problem, either with the ExifToolGUI remove metadata tactic described above or by using that same program to transfer the exif data from a corresponding jpeg to the tif file...

As I progressed, I did realize however that all the tifs that would not accept a change to the timestamp by XNView had been processed in RawTherapee and saved, importantly, as a compressed tif. Files processed in RawTherapee, saved as tifs, but not compressed kept their metadata.

Let me know if, despite that, you would still like me to send a file that had the problem. I'm asking again just because tif=huge file; if there's no point perhaps you don't want to clog up the server.

Faites-moi savoir!

EDIT: Or more so I'll try to recreate the problem tomorrow. Stay tuned.

KLE

KLE-France
Posts: 10
Joined: Mon Jan 14, 2019 3:00 pm

Re: Change timestamp tool not working with tif files

Post by KLE-France » Sat Oct 05, 2019 8:19 am

KLE-France wrote:
Fri Oct 04, 2019 5:33 pm
EDIT: Or more so I'll try to recreate the problem tomorrow. Stay tuned.
Bonjour Pierre,

Sigh, no, I'm not able to recreate a file that has this problem. Now, when I export from RawTherapee as a tif with compression it maintains the exif info correctly and I can change the timestamp directly in XNView MP.

Hypotheses:
  • RawTherapee eliminated the problem in an update?
  • The problem was inherent to .dng files (was using a Pentax camera at the time; now shooting Nikon)?
  • The problem may has something to do with Gimp, which, at the time (I don't know if it is still the situation), could not export exif data in a tif file (at the time I was processing raws in RawTherapee then retouching in Gimp)?
  • ...?
Désolé !

Let me know if you would still like a file that had the problem (but now has a timestamp via workarounds).

KLE

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Change timestamp tool not working with tif files

Post by xnview » Thu Oct 10, 2019 11:44 am

KLE-France wrote:
Sat Oct 05, 2019 8:19 am
Let me know if you would still like a file that had the problem (but now has a timestamp via workarounds).
yes please
Pierre.

KLE-France
Posts: 10
Joined: Mon Jan 14, 2019 3:00 pm

Re: Change timestamp tool not working with tif files

Post by KLE-France » Sat Oct 12, 2019 1:14 pm

xnview wrote:
Thu Oct 10, 2019 11:44 am
KLE-France wrote:
Sat Oct 05, 2019 8:19 am
Let me know if you would still like a file that had the problem (but now has a timestamp via workarounds).
yes please
Bonjour Pierre,

I'm getting a "too large" message when I try to attach one of the tif files to a forum post, so I sent you a PM with a link to one.

Thanks et très bon week-end à vous!
KLE

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Change timestamp tool not working with tif files

Post by xnview » Mon Oct 14, 2019 9:16 am

i have no problem with 0.93.1, if you try to change EXIF date only, same problem?
Pierre.

KLE-France
Posts: 10
Joined: Mon Jan 14, 2019 3:00 pm

Re: Change timestamp tool not working with tif files

Post by KLE-France » Wed Oct 16, 2019 8:04 am

xnview wrote:
Mon Oct 14, 2019 9:16 am
i have no problem with 0.93.1, if you try to change EXIF date only, same problem?
Bonjour Pierre,

The file that I sent you had already been "repaired", so to speak, using ExifToolGUI as explained in the EDIT of my original message. So, yes, in the file that I sent you, the timestamp can now be changed without any issues.

Hélas, I had already repaired all of the affected files using ExifToolGUI upstream of your initial response on Friday, October 4. Furthermore I could not recreate the problem.

Sorry for all that. I announced a problem and am now unable to help you solve it! :(

For what it's worth, my suspicions are now turning toward earlier versions of Gimp, which were unable to include exif data when an image was exported as a tif file. I don't use Gimp anymore, so I do not know if this is still the case.

Sorry again. I said above that I've repaired "all" of the affected files, but I have some 6000+ images on my computer. Should I stumble upon a heretofore undiscovered file with this problem, I'll be sure to send it to you.

Très bonne journée à vous,
KLE

Post Reply