0.93.1: EXIF Date is not correctly shown in Details (after Attribute Changer)

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
arspr
Posts: 76
Joined: Sat Mar 25, 2017 12:25 pm

0.93.1: EXIF Date is not correctly shown in Details (after Attribute Changer)

Post by arspr » Sun Apr 21, 2019 6:28 pm

XnView: MP 0.93.1 64 bit
OS: Windows 10 64bit

After the use of Attribute Changer the EXIF Date is not correctly shown in Detail View but it seems fully correct in EXIF Tab. Weird.

Just look at the screenshot I upload. All the EXIF Date times are shown as 0:00:00.

I intended to upload the picture shown in the screenshot but this forum didn't allow me because of its file size. Therefore I've just shot a dummy picture with the smallest resolution (and size) I can set. The issue is fully replicable there. I upload the original picture from camera and the modified one after using AC.

(My original issue was I forgot to update the summer time setting in my camera. Therefore I used Attribute Changer to add one hour to my pictures. I don't know if Attribute Changer is doing something wrong, but nevertheless it's pretty weird that EXIF Tab is working fine but EXIF Date in Detail View isn't.)
Attachments
04210001 After AC.JPG
04210001 From Camera.JPG
Screenshot - Wrong EXIF Date.jpg

User avatar
xnview
Author of XnView
Posts: 31504
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.93.1: EXIF Date is not correctly shown in Details (after Attribute Changer)

Post by xnview » Tue Apr 23, 2019 7:27 am

there is a problem in the date written "2019:04:21 21:13:442019:04:21 21:13:44", as you an see the field contains 2 dates...
Pierre.

arspr
Posts: 76
Joined: Sat Mar 25, 2017 12:25 pm

Re: 0.93.1: EXIF Date is not correctly shown in Details (after Attribute Changer)

Post by arspr » Tue Apr 23, 2019 7:04 pm

xnview wrote:
Tue Apr 23, 2019 7:27 am
there is a problem in the date written "2019:04:21 21:13:442019:04:21 21:13:44", as you an see the field contains 2 dates...
Ok Pierre, thanks. Please, would you mind elaborating a bit more in order to inform AC coders of their bug?

(I mean which field/metadata/EXIF property/whatever_it_is_called is affected by it. Xn View's EXIF Tab does not show anything wrong so I don't know where the bug is).

User avatar
xnview
Author of XnView
Posts: 31504
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.93.1: EXIF Date is not correctly shown in Details (after Attribute Changer)

Post by xnview » Wed Apr 24, 2019 4:31 pm

the EXIF date taken has this value
Pierre.

arspr
Posts: 76
Joined: Sat Mar 25, 2017 12:25 pm

Re: 0.93.1: EXIF Date is not correctly shown in Details (after Attribute Changer)

Post by arspr » Fri Apr 26, 2019 2:30 pm

Hi, Pierre.

Problem fixed AC. It was a bug in its used FPExif library.

Nevertheless, while fixing it, the guys behind the scenes also say that XnView has some trouble as it's not strictly following the EXIF specification (at least in that Detail view).

I copy the comment Romain Petges (AC coder) has emailed me:
[...]However, the EXIF specification clearly states a fixed length for this type of data. This means that XnView does not fully follow the specifications and ignores the length parameter. The developer of XnView should also modify the code to prevent such issues with maybe other EXIF libraries.[...]
All the technical conversation between Romain Petges and FPExit coder is here: https://forum.lazarus.freepascal.org/in ... .msg319117 and more specifically in the 3d reply.

User avatar
xnview
Author of XnView
Posts: 31504
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.93.1: EXIF Date is not correctly shown in Details (after Attribute Changer)

Post by xnview » Mon Apr 29, 2019 8:49 am

arspr wrote:
Fri Apr 26, 2019 2:30 pm
I copy the comment Romain Petges (AC coder) has emailed me:
[...]However, the EXIF specification clearly states a fixed length for this type of data. This means that XnView does not fully follow the specifications and ignores the length parameter. The developer of XnView should also modify the code to prevent such issues with maybe other EXIF libraries.[...]
All the technical conversation between Romain Petges and FPExit coder is here: https://forum.lazarus.freepascal.org/in ... .msg319117 and more specifically in the 3d reply.
Right...
Pierre.

Post Reply