0.92: Eats up the entire volume of the pagefile when generating thumbnails

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
X-Starter
Posts: 5
Joined: Sun Nov 11, 2018 12:59 am

0.92: Eats up the entire volume of the pagefile when generating thumbnails

Post by X-Starter » Sun Nov 11, 2018 1:47 am

XnView: MP 0.92 - 64-bit
OS: Windows 7 - 64-bit

Effect: The entire volume of the pagefile is filled when the XnView generating thumbnails. Pagefile-dependent programs crashes, and no longer run while the XnView is running, e.g. internet browsers.

To reproduce:
1. Enable in "General" settings, "ICC" tab, "Use ICC profile for monitor (slower)".
2. Choose "System" radio button, where is the calibrated monitor profile.
3. In thumbnail browser, enter the folder containing many images (jpg), e.g. 100~200.

P.S. No other settings have changed, I also deleted the folder "XnViewMP" in "AppData\Roaming", for cleanliness.

User avatar
xnview
Author of XnView
Posts: 30122
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.92: Eats up the entire volume of the pagefile when generating thumbnails

Post by xnview » Tue Nov 13, 2018 12:25 pm

could you send me some file samples that you browse?
Pierre.

X-Starter
Posts: 5
Joined: Sun Nov 11, 2018 12:59 am

Re: 0.92: Eats up the entire volume of the pagefile when generating thumbnails

Post by X-Starter » Tue Nov 13, 2018 6:02 pm

xnview wrote:
Tue Nov 13, 2018 12:25 pm
could you send me some file samples that you browse?
Here.
Attachments
003_1L7A2481.jpg
002_1L7A2464.jpg
001_1L7A2284.jpg

User avatar
xnview
Author of XnView
Posts: 30122
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.92: Eats up the entire volume of the pagefile when generating thumbnails

Post by xnview » Thu Nov 15, 2018 9:19 am

if you disable ICC, no such problem? I don't see any difference if ICC is off/on
Pierre.

X-Starter
Posts: 5
Joined: Sun Nov 11, 2018 12:59 am

Re: 0.92: Eats up the entire volume of the pagefile when generating thumbnails

Post by X-Starter » Thu Nov 15, 2018 11:26 am

xnview wrote:
Thu Nov 15, 2018 9:19 am
if you disable ICC, no such problem? I don't see any difference if ICC is off/on
Yes, the problem is present only when the ICC mode is on. The problem is not with all JPEG files.
The folder must contain at least 50+ images for the pagefile to start filling up, and more than 100+ images for it to be completely filled with the XnView. (32 GB in my case)
RAM can remain gigabytes, this error utilize only the pagefile.
Maybe my monitor ICC profile can help? It is calibrated by X-Rite Eye-one.
I also attach an image where I look at the pagefile usage, for cleanliness.
Attachments
Pagefile Usage Example.gif
Pagefile Usage Example.gif (43.35 KiB) Viewed 62 times
X-Rite Eye-one My LG.zip
(6.35 KiB) Downloaded 1 time

User avatar
xnview
Author of XnView
Posts: 30122
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.92: Eats up the entire volume of the pagefile when generating thumbnails

Post by xnview » Fri Nov 16, 2018 10:35 am

i've tried like that:
- 2 folders, one empty, and one with 100+ images
- disable Catalog
- start XnViewMP in empty folder
- go to folder with ICC images
- return to empty, and go back.
- No problem on Windows 10, memory stay stable...
Pierre.

X-Starter
Posts: 5
Joined: Sun Nov 11, 2018 12:59 am

Re: 0.92: Eats up the entire volume of the pagefile when generating thumbnails

Post by X-Starter » Fri Nov 16, 2018 12:47 pm

xnview wrote:
Fri Nov 16, 2018 10:35 am
i've tried like that:
- 2 folders, one empty, and one with 100+ images
- disable Catalog
- start XnViewMP in empty folder
- go to folder with ICC images
- return to empty, and go back.
- No problem on Windows 10, memory stay stable...
Perhaps the thumbnails for your images have already been created and taken from the cache? This only happens when generating new thumbnails.
I recorded a video, how it happens, maybe it will help.
Attachments
XnView.mp4
(1.2 MiB) Downloaded 3 times

User avatar
xnview
Author of XnView
Posts: 30122
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.92: Eats up the entire volume of the pagefile when generating thumbnails

Post by xnview » Fri Nov 16, 2018 1:45 pm

X-Starter wrote:
Fri Nov 16, 2018 12:47 pm
Perhaps the thumbnails for your images have already been created and taken from the cache? This only happens when generating new thumbnails.
I recorded a video, how it happens, maybe it will help.
No, i disable the catalog, to be sure that SQLIte doesn't reserve some memory...

I've tried on Win 7, and no problem here too. Could you try to disable catalog?
Pierre.

X-Starter
Posts: 5
Joined: Sun Nov 11, 2018 12:59 am

Re: 0.92: Eats up the entire volume of the pagefile when generating thumbnails

Post by X-Starter » Fri Nov 16, 2018 1:57 pm

xnview wrote:
Fri Nov 16, 2018 1:45 pm
X-Starter wrote:
Fri Nov 16, 2018 12:47 pm
Perhaps the thumbnails for your images have already been created and taken from the cache? This only happens when generating new thumbnails.
I recorded a video, how it happens, maybe it will help.
No, i disable the catalog, to be sure that SQLIte doesn't reserve some memory...

I've tried on Win 7, and no problem here too. Could you try to disable catalog?
Disabled Catalog, the problem continues to be present.
I suspect that the size of the thumbnails also affects the amount of pagefile eaten.

mudo_j
Posts: 8
Joined: Fri Feb 17, 2017 7:01 pm

Re: 0.92: Eats up the entire volume of the pagefile when generating thumbnails

Post by mudo_j » Fri Nov 16, 2018 2:48 pm

If this is related to
viewtopic.php?t=37085
it might be Windows 7 specific. My final workaround was installing Windows 10.

And while it did happen on three Windows 7 computers, that I have tried, I can't reproduce the issue on a Windows 7 virtual machine.

Post Reply