Assigning Category: slow

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
alobo
Posts: 36
Joined: Sun Jun 18, 2017 3:24 pm

Assigning Category: slow

Post by alobo » Sun Aug 12, 2018 4:21 pm

When a select a bunch of pictures (e.g., 50) to tag them with a common Category,
the system remains unresponsive for a while. As far as I can see, after few seconds
the tags have been assigned, but I find very confusing that once the user selects a
category there is no Apply button and there is no message telling the user to wait while
the category is being assigned to each picture.
Or perhaps I'm doing something wrong...

User avatar
xnview
Author of XnView
Posts: 29744
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Assigning Category: slow

Post by xnview » Mon Aug 13, 2018 7:46 am

which format? what are your settings in 'Metadata'?
Pierre.

alobo
Posts: 36
Joined: Sun Jun 18, 2017 3:24 pm

Re: Assigning Category: slow

Post by alobo » Mon Aug 13, 2018 10:47 am

This is what I have, perhaps not the best?
https://www.dropbox.com/s/shg6fulmn56vb ... s.JPG?dl=0

User avatar
xnview
Author of XnView
Posts: 29744
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Assigning Category: slow

Post by xnview » Tue Aug 14, 2018 9:26 am

so category are written in the file itself. But which format of pictures?
Pierre.

alobo
Posts: 36
Joined: Sun Jun 18, 2017 3:24 pm

Re: Assigning Category: slow

Post by alobo » Tue Aug 14, 2018 2:14 pm

xnview wrote:
Tue Aug 14, 2018 9:26 am
so category are written in the file itself. But which format of pictures?
JPG right now, but I will be using RAW and tif as well.

User avatar
xnview
Author of XnView
Posts: 29744
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Assigning Category: slow

Post by xnview » Tue Aug 14, 2018 2:32 pm

If you select 50 JPG it's slow? do you assign category in the bottom category pane?
Pierre.

alobo
Posts: 36
Joined: Sun Jun 18, 2017 3:24 pm

Re: Assigning Category: slow

Post by alobo » Tue Aug 14, 2018 3:06 pm

xnview wrote:
Tue Aug 14, 2018 2:32 pm
If you select 50 JPG it's slow? do you assign category in the bottom category pane?
Yes, I use this:
https://www.dropbox.com/s/z5g2k1m82vpuq ... s.JPG?dl=0

and the the program is unresponsive for a while.

What bothers me most is the fact that once you click a box there is no an Apply button, it seem the Category is immediately written. It is very easy to click a wrong box, an Apply button would be safer. Also,
you could select several different boxes and then Apply. And get a "Wait..." message or something while the program works.

User avatar
xnview
Author of XnView
Posts: 29744
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Assigning Category: slow

Post by xnview » Tue Aug 14, 2018 3:38 pm

alobo wrote:
Tue Aug 14, 2018 3:06 pm
What bothers me most is the fact that once you click a box there is no an Apply button, it seem the Category is immediately written. It is very easy to click a wrong box, an Apply button would be safer. Also,
you could select several different boxes and then Apply. And get a "Wait..." message or something while the program works.
the categories are written when you change the image selection.

could you send me one or more file samples that you use?
Pierre.

alobo
Posts: 36
Joined: Sun Jun 18, 2017 3:24 pm

Re: Assigning Category: slow

Post by alobo » Wed Aug 15, 2018 6:20 pm

[/quote]
the categories are written when you change the image selection.

could you send me one or more file samples that you use?
[/quote]

I had that impression: nothing happens until you try to select another photo. Anyway, it's very confusing, much better having
an apply button.

Sent a link privately.
Agus

Post Reply