Two items in 0.86 that bother me.

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
Dominius
Posts: 34
Joined: Mon Nov 28, 2016 9:58 am

Two items in 0.86 that bother me.

Post by Dominius » Tue Aug 01, 2017 3:27 pm

First, Unicode support. I paste in a letter with a diaeresis from KDE Character Select into a text file I'll use Exiftool (again, version 10.56 -- so much newer that the "embedded" one in your app it's almost laughable) to write into a JPEG file, and when I view that data --- let's say it's an IPTC Caption --- it has one of these symbols in place of the accented letter:�. I know the rule of the IPTC standard that only ASCII is allowed due to cross-platform issues. But if you are claiming XnView MP has any Unicode support, I present the above example to argue that it is not.

Second, access to the "Edit IPTC/XMP" command in the right-click menu in Browser mode should be moved to the Edit or View menus in ordinary View mode, as it was in Classic a few versions back, or copied to one of those menus. I know it's no big deal to switch back to Browser view by clicking on the appropriate tab, but I find that interrupts workflow.

So those are my issues, minor as they are. Could they be addressed in a future dot-upgrade to MP? Or will one have to wait for 1.0?

Dominius

User avatar
xnview
Author of XnView
Posts: 30122
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Two items in 0.86 that bother me.

Post by xnview » Tue Aug 01, 2017 8:22 pm

you need to change settings>Metadata>Encoding
Pierre.

Dominius
Posts: 34
Joined: Mon Nov 28, 2016 9:58 am

Re: Two items in 0.86 that bother me.

Post by Dominius » Mon Nov 05, 2018 6:43 am

Sorry to resurrect such an old thread, but...

I presume you meant, in Settings>Metadata>Encoding, to change from "Locale" to "UTF-8." I did that and now I'm going to look for a pic that displayed the garbage character in its IPTC Caption. I'll add another post to this thread if there's been no change.

Dominius
PS: Thanks for keeping up with Exiftool. Even in XnView MP 0.88, it's newer than mine (10.61 vs 10.40). Must have something to do with the fact that Ubuntu doesn't have the latest versions on its repositories for my Kubuntu 17.04, which isn't even supported nor is everything in their "old versions" repositories anymore.

Dominius
Posts: 34
Joined: Mon Nov 28, 2016 9:58 am

Re: Two items in 0.86 that bother me.

Post by Dominius » Fri Nov 09, 2018 7:21 pm

Captions will not display the correct letters, but XMP Dublin Core Descriptions do, when the setting is as I described in my last post.
I seem to remember, back when Gwenview and Kipi's Metadata plugins were working correctly (maybe two or three years ago?), that there was a warning that that app's IPTC was strictly ASCII for your locale, in keeping with the standard at that time. I this is still true with the standard, but I haven't researched it so I can't say for sure.

D
PS: Can anything be done about the small size of the window for Caption (in the dialog accessed via Ctrl-I)? Even Nautilus and Nemo give more space than MP does, and those apps aren't strictly for graphic or movie files.

Post Reply