Bug or Feature?

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
jadO
Posts: 410
Joined: Wed Apr 29, 2015 6:36 am

Bug or Feature?

Post by jadO » Sun Oct 04, 2015 5:23 am

When you enter a folder and select to show all pictures recursively. And then when you select one picture and double click it.
After that you close the picture and you see the explorer again, but no more recursive anymore. You only see the current folder.

It would be much better if you close the picture and if you go back to explorer the view is still recursively.

Teo
Posts: 17
Joined: Sat Sep 12, 2015 9:31 pm

Re: Bug or Feature?

Post by Teo » Mon Oct 05, 2015 1:09 am

I was able to reproduce this error. Let me add more info:

THIS DOESN'T WORK:
1. Click settings > interface > switching mode
2. Set double click to "browser <> viewer"
3. Select a folder that has subfolders in it
4. On top click the button "show files in subfolder". On the screen it will show all pictures in all subfolders within this main folder that is selected.
5. Now double click on one of the pictures
6. The picture opens in a new tab. Close this tab.
7. Instead returning to the main folder, it incorrectly returns to the subfolder this picture is located.

Interestingly, if you change the setting in step 2, it works correctly

THIS WORKS:
1. Click settings > interface > switching mode
2. Set double click to "Browser <> Fullscreen | Viewer <> Fullscreen "
3. Select a folder that has subfolders in it
4. On top click the button "show files in subfolder". On the screen it will show all pictures in all subfolders within this main folder that is selected.
5. Now double click on one of the pictures
6. It correctly returns to the main folder

---

This error is similar to video playback error. Double clicking on videos is broken if the double click is set to "browser <> viewer" but it works fine in "Browser <> Fullscreen | Viewer <> Fullscreen ".

Tested with xnviewmp 0.72, 32 bit on 32 bit win XP

jadO
Posts: 410
Joined: Wed Apr 29, 2015 6:36 am

Re: Bug or Feature?

Post by jadO » Fri Oct 11, 2019 6:08 am

Teo wrote:
Mon Oct 05, 2015 1:09 am
Interestingly, if you change the setting in step 2, it works correctly

THIS WORKS:
1. Click settings > interface > switching mode
2. Set double click to "Browser <> Fullscreen | Viewer <> Fullscreen "
3. Select a folder that has subfolders in it
4. On top click the button "show files in subfolder". On the screen it will show all pictures in all subfolders within this main folder that is selected.
5. Now double click on one of the pictures
6. It correctly returns to the main folder

---

This error is similar to video playback error. Double clicking on videos is broken if the double click is set to "browser <> viewer" but it works fine in "Browser <> Fullscreen | Viewer <> Fullscreen ".

Tested with xnviewmp 0.72, 32 bit on 32 bit win XP
After applying this step and switching back to "browser <> viewer" it keeps working in 0.94b2.
So maybe it has been fixed.

Post Reply