BMP image broken in XnView, displays correctly in MSPaint

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply

User avatar
oops66
XnThusiast
Posts: 1999
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: BMP image broken in XnView, displays correctly in MSPain

Post by oops66 » Tue Apr 27, 2010 6:07 pm

Hobbe wrote:Download it from here and see if you can confirm.
Cheers.
Hello,
I can not confirm here XnView 1.97-3
Try to do "Ctrl+H" shortcut ( Use/hide alpha channel)
(works into MP0.26 too)
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Re: BMP image broken in XnView, displays correctly in MSPain

Post by Clo » Tue Apr 27, 2010 6:13 pm

:arrow: Hobbe

:) Hello !

• Yes, it's broken in XnView 1.97.3 (and also in Imagine)… as long as you don't press CTRL+H, same in MP 0.26-1;
it works directly in Paint, Opera browser and Universal Viewer…
- It's shown as 32 BPP, but in GreenFish which supports 32BPP-BMP, only as 24 BPP (don't ask me why…) :?:

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 32081
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: BMP image broken in XnView, displays correctly in MSPain

Post by xnview » Fri Jun 04, 2010 9:16 am

The problem is not XnView, but the alpha of this BMP
If you remove alpha channel, the picture is good
Pierre.

Post Reply