Strange 'effect' in fullscreen

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Strange 'effect' in fullscreen

Post by Dreamer » Thu Jan 29, 2009 2:17 am

I had this issue few times with older versions, with the current version - 1.95.4 and also with the latest beta (3). I couldn't reproduce it, but it's getting quite annoying...

First, there is a grey area in fullscreen when I open image from explorer, then when I switch view to browser, it's OK, but in view mode the size of the window is changed almost to fullscreen, but it's not fullscreen - so the viewer window size is lost. When I resize the Viewer window, it will solve also the grey area problem at start.

Image

Win Vista SP1.
Dreamer

pic_viewer
Posts: 251
Joined: Sat Nov 17, 2007 7:53 am
Location: Germany

Re: Strange 'effect' in fullscreen

Post by pic_viewer » Thu Jan 29, 2009 5:39 am

Same here. I tracked this down (maybe) to a problem with the Viewer window size. If it is like maximized but is not (means manually changd to nearly full screen size, with the window's statusbar hiding behind the taskbar).

It vanished after I resized the window so it is no longer behind the taskbar. After that I tried to reproduce it by making the window bigger to nearly maximized again, but couldn't. Also I can not remember to have set the window to that size/position before, so have no clue what triggered this in the first place.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Thu Jan 29, 2009 6:29 pm

Viewer window size is about half screen, then, when I open image from explorer (or file manager), I have this strange effect and then, when I switch to viewer, the size is almost maximized - so the window is 'almost maximized' automatically. It happened once, or twice when I opened image from USB drive, or SD card reader, but last time it was the local hard drive (SATA II). Anyway, you can test to open image from card reader, USB flash drive, even if I tried it already, but I couldn't reproduce it. It's a very strange issue. :?
Dreamer

User avatar
GeorgD
Posts: 283
Joined: Thu Oct 12, 2006 2:45 pm

Grey area at right border

Post by GeorgD » Mon Oct 26, 2009 5:29 pm

Hello, full screen works fine here, but I have a grey area at right border in viewer, window is maximized, Win 7 64bit RC1. It is as high as the image is shown and exactly 2px wide. It's not hurting but a little irritating 8) Screenshot at http://yfrog.com/0c20091023xnview196j
In the XnView Wiki, you can improve the user guide / documentation / F1-help for XnView (classic/Windows) and for XnViewMP

User avatar
XnTriq
Moderator & Librarian
Posts: 5431
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Grey area at right border

Post by XnTriq » Mon Oct 26, 2009 6:45 pm

GeorgD wrote:Hello, full screen works fine here, but I have a grey area at right border in viewer, window is maximized, Win 7 64bit RC1. It is as high as the image is shown and exactly 2px wide.
Sounds like that infamous problem with Aero theme.

User avatar
GeorgD
Posts: 283
Joined: Thu Oct 12, 2006 2:45 pm

Re: Grey area at right border

Post by GeorgD » Mon Oct 26, 2009 11:31 pm

XnTriq wrote:Sounds like that infamous problem with Aero theme.
Yes, I answered there to keep topics seperated.
In the XnView Wiki, you can improve the user guide / documentation / F1-help for XnView (classic/Windows) and for XnViewMP

Post Reply