Keywords multiple problems

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, helmut, xnview

30 west
Posts: 5
Joined: Wed Aug 23, 2023 10:39 pm

Keywords multiple problems

Post by 30 west »

I am nearly going insane trying to resolve this. I have watched several YouTube tutorials. the Carl Seibert ones are awesome, but the menu items and many other features have changed since that was done. I am using MacOS XnViewMP 1.5.3 (Aug 11, 2023).

Mainly, I think my issues are based on NOT being able to create OR import a list of Lightroom keywords. In the CATEGORIES panel, -Category management, import categories file: I choose Lightroom Keywords.txt. All the dialog works except I can't find any resulting imported keywords anywhere. Have tried this multiple times and like Einstein said about doing the same thing but expecting different results...

Menu-View-Info Panels: select IPTC-IIM but does not appear in info panel
Menu-View-Info Panels: no item for "properties" listed but it (properties) DOES appear in Info panel
Categories Panel: try to add new keyword. get (create new) prompt and OK it. the "new" keyword simply disappears. not found anywhere.
Settings (formerly preferences)-Labels try to add categories exactly per tutorial video (Seibert)...does not work (no categories in labels)
Settings-Browse-Tooltips: added categories AND keywords per tutorial...does not work...tool tips do not include selected items
'
So maybe if I could actually import my keywords list, then have them show up in Categories panel, then be able to select them to write to files, maybe some of these other problems would be irrelevant.

I almost wonder if my installation got somehow corrupted, but all of this was present BEFORE downloading the latest version, so it would seem unlikely that I would have faulty installations of two versions of the software. I will test these issues on a linux laptop to see if it is affecting Mac only...but that seems unlikely.

Honestly, I have tried all the "self help" I can find, so any solutions will be greatly appreciated
30 west
Posts: 5
Joined: Wed Aug 23, 2023 10:39 pm

Re: Keywords multiple problems

Post by 30 west »

Follow up from original post, after looking at another laptop (also Mac and same version of XnViewMP)...

Alternate laptop seemed to be working "Okay", discovered that "problem" laptop apparently had missing "db" files. Could not re-create database with new installation. Have no idea how "functional" laptop created the database and "problem" laptop could not create one. When I copied the database folder to the "problem" laptop all started working OK.

I ASSUMED that an new installation could start with an import of Lightroom Keywords, then follow up with assigning those existing keywords to folders of photos.

Remaining question is how one creates a new database from scratch on a new (clean) installation.

thanks
User avatar
xnview
Author of XnView
Posts: 44030
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Keywords multiple problems

Post by xnview »

By replacing the .db, all works now??
Pierre.
30 west
Posts: 5
Joined: Wed Aug 23, 2023 10:39 pm

Re: Keywords multiple problems

Post by 30 west »

Oui Pierre, merci mais (I don’t want to insult you or anyone with my weak Francais)

I uninstalled XnView on the “problem” laptop and reinstalled expecting that a new empty “db” folder would be created, but it did not. So that is why I resorted to copying that folder from another source.

My question remains: How does one CREATE the “db” files / folder in the first place if installing on a brand new computer? I do not remember how that happened on the “good” laptop and can not repeat the process on the other one.

Je vous remerci beaucoup.

Gary
User avatar
xnview
Author of XnView
Posts: 44030
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Keywords multiple problems

Post by xnview »

30 west wrote: Sat Aug 26, 2023 3:11 pm My question remains: How does one CREATE the “db” files / folder in the first place if installing on a brand new computer? I do not remember how that happened on the “good” laptop and can not repeat the process on the other one.
By default a new database is created, so it's strange. What do you have in settings>Integration>Paths?
Pierre.
30 west
Posts: 5
Joined: Wed Aug 23, 2023 10:39 pm

Re: Keywords multiple problems

Post by 30 west »

Using a Mac the folder lives: MacHD/Users/gary/Pictures/catalogs/xnview.

When I uninstalled and then reinstalled, this folder obviously would not exist. The programs has to be installed before one can enter settings to modify it…so I assume there must be a default location that exists on installation.

It MAY be that, changing the default in Settings left the original “db” files in place and the addition of a NEW path didn’t bring over those files. I will do another uninstall / fresh install cycle to see if that is where the chain was broken.

Merci encore

Gary
User avatar
xnview
Author of XnView
Posts: 44030
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Keywords multiple problems

Post by xnview »

By default it's not this folder, but $HOME/.xnviewmp
Pierre.
30 west
Posts: 5
Joined: Wed Aug 23, 2023 10:39 pm

Re: Keywords multiple problems

Post by 30 west »

Got it...thanks.