Preview thumbnails are not rotated

*** Please report new bugs here! ***

Moderators: helmut, XnTriq, xnview, Dreamer

User avatar
xnview
Author of XnView
Posts: 37882
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Preview thumbnails are not rotated

Post by xnview »

i've tried your 2 files, and the orientation is correct
Clipboard-1.png
You do not have the required permissions to view the files attached to this post.
Pierre.
bege
Posts: 65
Joined: Sun Feb 20, 2011 6:27 pm
Location: Germany

Re: Preview thumbnails are not rotated

Post by bege »

xnview wrote: Sun Jan 09, 2022 3:14 pm i've tried your 2 files, and the orientation is correct
Do you have an idea why it is not here? It still looks like in my screenshot above. In browser view only DSCN0666_1.jpg is portrait and the exif rotation icon is displayed.
User avatar
xnview
Author of XnView
Posts: 37882
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Preview thumbnails are not rotated

Post by xnview »

could you try 'View>Update catalog from files'?
Pierre.
bege
Posts: 65
Joined: Sun Feb 20, 2011 6:27 pm
Location: Germany

Re: Preview thumbnails are not rotated

Post by bege »

xnview wrote: Mon Jan 10, 2022 7:52 am could you try 'View>Update catalog from files'?
Still the same. Make new thumbnails did not change anything either.

Then I renamed Thumb.db to Thumb.db.bak. XnV created a new Thumb.db and that solved the issue - until the next start of XnV. Then it was as before. I toggled the pref. "Use embedded thumbnails" and restarted the program in between - still the same.

Edit 1: I turned another image from landscape to portrait: ExifTool now shows "Rotate 90 CW", Exif "right-top", in image view the information feature of XnV shows for this file the same orientation as for the not turned images in landscape mode "top-left".

Edit 2: I renamed both Thumb.db and XnView.db and the correct orientation survived 5 starts of XnV.
Is the database corrupt? Is there a routine to repair it? (I made an integrity check with a database editor: OK.)

(The wrong orientation information in image view remained. So that might be a different issue.)
User avatar
xnview
Author of XnView
Posts: 37882
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Preview thumbnails are not rotated

Post by xnview »

bege wrote: Mon Jan 10, 2022 12:39 pm Then I renamed Thumb.db to Thumb.db.bak. XnV created a new Thumb.db and that solved the issue - until the next start of XnV. Then it was as before. I toggled the pref. "Use embedded thumbnails" and restarted the program in between - still the same.
That's crazy, do you have made a change on the file (edit iptc, ...)?
Pierre.
bege
Posts: 65
Joined: Sun Feb 20, 2011 6:27 pm
Location: Germany

Re: Preview thumbnails are not rotated

Post by bege »

xnview wrote: Tue Jan 11, 2022 3:57 pm
bege wrote: Mon Jan 10, 2022 12:39 pm Then I renamed Thumb.db to Thumb.db.bak. XnV created a new Thumb.db and that solved the issue - until the next start of XnV. Then it was as before. I toggled the pref. "Use embedded thumbnails" and restarted the program in between - still the same.
That's crazy, do you have made a change on the file (edit iptc, ...)?
No, I simply rotated the files to portrait with the respective button.

I did more testing with old and new Thumb.db and Xnview.db
Before I can say something about the result I noticed that there is an issue with rotating in image view. Even with the new Xnview.db sometimes it does not rotate at all, sometimes the issue with wrong orientation in browser view is there also. If I rotate the images in browser view everything is OK with the new Xnview.db.
In both views I use the same buttons: cmd_rotate270 and cmd_rotate_90. If I use it in browser view the image rotates without any other action and everything is OK. (Pref. Only change EXIF orientation if possible) When I use the same buttons in image view I receive a notification to save the image and the mentioned issues occur.
Can you, please, have a look at that before I do more testing with the old Xnview.db?
User avatar
xnview
Author of XnView
Posts: 37882
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Preview thumbnails are not rotated

Post by xnview »

Ok, i can reproduce only with "Only change EXIF orientation if possible". In 0.99.7, "update catalog from files" update correctly the orientation...
Pierre.
bege
Posts: 65
Joined: Sun Feb 20, 2011 6:27 pm
Location: Germany

Re: Preview thumbnails are not rotated

Post by bege »

xnview wrote: Thu Jan 13, 2022 1:00 pm Ok, i can reproduce only with "Only change EXIF orientation if possible". In 0.99.7, "update catalog from files" update correctly the orientation...
It is really weird here. Have a look at this
Screenshot_303.png
Screenshot_304.png
This is also after rebuilding the catalog, no matter whether "use embedded thumbnail" is active or not.

Why is there the described difference between rotating in browser and image view? The latter creates the issues here. Rotating in browser view without save dialog works fine.
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 37882
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Preview thumbnails are not rotated

Post by xnview »

bege wrote: Thu Jan 13, 2022 6:32 pm This is also after rebuilding the catalog, no matter whether "use embedded thumbnail" is active or not.
you have tried with latest version?
Why is there the described difference between rotating in browser and image view? The latter creates the issues here. Rotating in browser view without save dialog works fine.
In 'edit mode', rotation is applied to image
Pierre.
bege
Posts: 65
Joined: Sun Feb 20, 2011 6:27 pm
Location: Germany

Re: Preview thumbnails are not rotated

Post by bege »

xnview wrote: Fri Jan 14, 2022 7:41 am
bege wrote: Thu Jan 13, 2022 6:32 pm This is also after rebuilding the catalog, no matter whether "use embedded thumbnail" is active or not.
you have tried with latest version?
Yes, 0.99.7
User avatar
xnview
Author of XnView
Posts: 37882
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Preview thumbnails are not rotated

Post by xnview »

so you have:
- General>Rotate images according to EXIF orientation
- Browser>Misc>Change EXIF orientation
- Browser>Misc>Use lossless if possible

in Browser, you click on the file, and rotate in toolbar, right?
Pierre.
bege
Posts: 65
Joined: Sun Feb 20, 2011 6:27 pm
Location: Germany

Re: Preview thumbnails are not rotated

Post by bege »

xnview wrote: Mon Jan 17, 2022 9:25 am so you have:
- General>Rotate images according to EXIF orientation
- Browser>Misc>Change EXIF orientation
- Browser>Misc>Use lossless if possible

in Browser, you click on the file, and rotate in toolbar, right?
Yes.

To get it work again I rotated and saved the respective files in image view with v0.99.7. Now I can rotate them in browser view and orientation is correct. Probably there was an issue with the files rotated with v0.99.6.
This was true only for the new Xnview.db until I once again deleted the Thumbs.db. Now the orientation is correct with my old Xnview.db also.
I did some tests with changing the orientation in browser and in image view and found no bugs. So I hope this issue is solved with v0.99.7. But perhaps other users may also have trouble with the db files before they rebuild the catalog and delete the Thumbs.db.

For this already mentioned issue I don't create a new bug report because it is closely related:
The information about orientation is wrong in image view:

Correct:
Screenshot_306.png
Wrong:
Screenshot_308_738x480.png
You do not have the required permissions to view the files attached to this post.
bege
Posts: 65
Joined: Sun Feb 20, 2011 6:27 pm
Location: Germany

Re: Preview thumbnails are not rotated

Post by bege »

Unfortunately the issue is back after editing images.

These 3 files come from a camera that notes the orientation.

This file I have not edited:
Screenshot_312.png
These two files I have edited (only colors, not orientation!):
Screenshot_311.png
In image view the orientation is OK, in browser view it is wrong.

Here are the files:
https://filehorst.de/d/edbfotls
You do not have the required permissions to view the files attached to this post.
bege
Posts: 65
Joined: Sun Feb 20, 2011 6:27 pm
Location: Germany

Re: Preview thumbnails are not rotated

Post by bege »

@xnview
I am afraid that editing images might corrupt rotation. I did not change rotation that comes from the camera when editing the two files. Please, compare data in ExifTools of all three files. The one I did not edit has consistent data about orientation/rotation, the two edited files have inconsistent data.
User avatar
xnview
Author of XnView
Posts: 37882
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Preview thumbnails are not rotated

Post by xnview »

bege wrote: Tue Feb 08, 2022 10:24 pm @xnview
I am afraid that editing images might corrupt rotation. I did not change rotation that comes from the camera when editing the two files. Please, compare data in ExifTools of all three files. The one I did not edit has consistent data about orientation/rotation, the two edited files have inconsistent data.
could you send me these 3 files?
Pierre.