Warning: 'Error opening the file'

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

Post Reply
nicks68
Posts: 9
Joined: Mon May 13, 2019 4:57 pm

Warning: 'Error opening the file'

Post by nicks68 » Mon May 13, 2019 5:05 pm

Hello, probably this have been posted again. When an image is in a file in my pc, xn-view dont open is and appears a warning with symbols, questions... When i copy the image to another file in my pc, then it opens fine! Whats wrong? Thank you!

User avatar
xnview
Author of XnView
Posts: 31732
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: xn-view warning

Post by xnview » Tue May 14, 2019 9:05 am

your filename has unicode characters?
Pierre.

nicks68
Posts: 9
Joined: Mon May 13, 2019 4:57 pm

Re: xn-view warning

Post by nicks68 » Thu May 16, 2019 11:38 am

No, i changed the file name. The problem is that an image opens with xnview only in a specifiec folder in my pc, but not in any folder. Example: blabla.jpg opens with xn view when blabla.jpg is at folder desktop. If i copy the blabla.jpg to another folder then i get something like this:
x WARNING
??&&@@??< blabla.jpg

I can show you with team viewer what happens! Thank you!

nicks68
Posts: 9
Joined: Mon May 13, 2019 4:57 pm

Re: xn-view warning

Post by nicks68 » Thu May 16, 2019 11:47 am

WARNING ?d?aμ? a a ?μate <C:\users\skobr\Documents\my math\my book\?etapt??.jpg

Thats what i get when i copy an image which opened in a specifiec folder, and after copy it to another folder. (os Windows 10)

nicks68
Posts: 9
Joined: Mon May 13, 2019 4:57 pm

Re: xn-view warning

Post by nicks68 » Thu May 16, 2019 12:15 pm

Here is what i discovered: If an image is in a folder which has a greek name (example οι φωτογραφίες μου) then xn view dont open it. If i change folder name in to english then xn view opens the file! How can i fix this? Thank you!

cday
XnThusiast
Posts: 2155
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: xn-view warning

Post by cday » Thu May 16, 2019 1:01 pm

nicks68 wrote:
Thu May 16, 2019 12:15 pm
If an image is in a folder which has a greek name (example οι φωτογραφίες μου) then xn view dont open it. If I change folder name in to English then xnview opens the file! How can I fix this?
XnView MP supports Unicode... :D

nicks68
Posts: 9
Joined: Mon May 13, 2019 4:57 pm

Re: xn-view warning

Post by nicks68 » Tue May 28, 2019 6:02 am

Good morning! The problem i descibed is only at my pc. I downloaded xnvied classic to another pc, i put an image in a folder with a greek name and xn view worked fine! At my pc, as i said, xn view dont open images which are in folders with greek names. What is wrong? Thank you!

cday
XnThusiast
Posts: 2155
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: xn-view warning

Post by cday » Tue May 28, 2019 7:17 am

nicks68 wrote:
Tue May 28, 2019 6:02 am
Good morning! The problem i descibed is only at my pc. I downloaded xnvied classic to another pc, i put an image in a folder with a greek name and xn view worked fine! At my pc, as i said, xn view dont open images which are in folders with greek names. What is wrong? Thank you!

Possibly different versions of XnView, limited Unicode support was added in 2.41 according to the Changelog...

nicks68
Posts: 9
Joined: Mon May 13, 2019 4:57 pm

Re: xn-view warning

Post by nicks68 » Tue May 28, 2019 11:26 am

Hello! Its the same version....do you think that my pc which was bought in england has something to do about the problem?

cday
XnThusiast
Posts: 2155
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: xn-view warning

Post by cday » Tue May 28, 2019 11:47 am

nicks68 wrote:
Tue May 28, 2019 11:26 am
Hello! Its the same version....do you think that my pc which was bought in england has something to do about the problem?
I'm sorry, I don't know enough about how Windows works to answer that... :(

Are you able to upload an example file that I can test later on one of my English computers? Preferably in a ZIP archive to ensure it arrives exactly as your copy.

nicks68
Posts: 9
Joined: Mon May 13, 2019 4:57 pm

Re: xn-view warning

Post by nicks68 » Tue May 28, 2019 12:09 pm

Hello...here is the same image in two different folders. The one with greek name xn view dont work, the other with english name xn view works fine! Thanks!
Attachments
Desktop.7z
(9.43 KiB) Downloaded 12 times

cday
XnThusiast
Posts: 2155
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: xn-view warning

Post by cday » Tue May 28, 2019 1:00 pm

On my British Windows 7 SP1 64-bit computer, XnView Classic 2.46 ZIP download doesn't open the file in the folder with a Greek name:


XnView Classic 2.46 Error message.png
XnView Classic 2.46 Error message.png (7.59 KiB) Viewed 527 times

Is there a reason why you don't wish to use XnView MP, which supports Unicode and opens the above file?

nicks68
Posts: 9
Joined: Mon May 13, 2019 4:57 pm

Re: xn-view warning

Post by nicks68 » Wed May 29, 2019 1:37 pm

Hello! Yes thats exactly the message i get! But i dont get any message using xn view classic to any pc was bought at Greece. (I have installed it at over 15 pc`s and laptops at the school i work, and it works fine!) . Seems that there is a small problem here which you should fix sometime or i must change an option at my windows. Im glad i made you see the problem! Anyway xn view MP has many options i dont really need. I will use MP untill a classic version in the future works with my british laptop! Thank you!

cday
XnThusiast
Posts: 2155
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: xn-view warning

Post by cday » Wed May 29, 2019 2:48 pm

I think you can probably configure your British computer the same way as your Greek computers by changing the Windows 'System Locale'... :D

This is the Control Panel setting in Windows 7, if necessary Google for your version of Windows:


Region and Language.png
Region and Language.png (24.21 KiB) Viewed 467 times

nicks68
Posts: 9
Joined: Mon May 13, 2019 4:57 pm

Re: Warning: 'Error opening the file'

Post by nicks68 » Wed May 29, 2019 6:07 pm

Hello!! That solved my problem!! My British laptop had English as the defult language for non unicode programs. I turned it to Greek and everything is ok!! Thank you very much!! :D :D

Post Reply