Copy and paste selection issues in image view, clipboard is to blame?

Moderators: cday, XnTriq, helmut, xnview, Dreamer

Post Reply
warmaker
Posts: 1
Joined: Fri Apr 19, 2019 4:14 pm

Copy and paste selection issues in image view, clipboard is to blame?

Post by warmaker » Fri Apr 19, 2019 7:57 pm

I am having a hard time copying and pasting parts/selection of image in view mode with XnViewMP (which I just installed after YEARS of using XnView Classic). It does work SOMETIMES (the FAILED positions), but I can't figure out under what conditions exactly.

Software I used:
- XnView Classic v2.48 (Mar 2 2019)
- XnViewMP Version 0.93.1 64bits (Mar 6 2019)
- Paint 1803 (OS Build 17134.706)
- Gimp 2.10.10
- Windows 10 Enterprise

And now...
Copying from ---> Copying to: RESULT. Remarks.

XnView Classic ---> XnView Classic: OK
XnView Classic ---> XnViewMP: FAILED (nothing happens). However, it is possible to "Import clipboard" (Ctrl+Shift+V).
XnView Classic ---> Paint: OK
XnView Classic ---> Gimp: OK
Gimp ---> XnView Classic: OK
Paint ---> XnView Classic: OK

XnViewMP (Ctrl+C) ---> XnViewMP: OK
XnViewMP (Ctrl+C) ---> XnView Classic: OK
XnViewMP (Ctrl+C) ---> Paint: OK
XnViewMP (Ctrl+C) ---> Gimp: FAILED (GIMP Message: There is no image data in the clipboard to paste)

XnViewMP (Ctrl+Shift+C) ---> XnViewMP: FAILED (nothing happens). However, it is possible to "Import clipboard" (Ctrl+Shift+V).
XnViewMP (Ctrl+Shift+C) ---> XnView Classic: OK
XnViewMP (Ctrl+Shift+C) ---> Paint: OK
XnViewMP (Ctrl+Shift+C) ---> Gimp: FAILED (GIMP Message: There is no image data in the clipboard to paste)

Paint ---> XnViewMP: FAILED (Nothing happens). However, it is possible to "Import clipboard" (Ctrl+Shift+V).
Gimp ---> XnViewMP: FAILED (Nothing happens). However, it is possible to "Import clipboard" (Ctrl+Shift+V).

I found out that there are different sets of data being copied to the clipboard from different programs. Please, see attached screenshots. Attachment/file name says which program this clipboard was copied from.

Any chance you could have a look at this? Thanks!
Attachments
Clipboard_ Paint.png
Clipboard_ GIMP.png
Clipboard_ XnView Classic Ctrl+C.png
Clipboard_ XnViewMP Ctrl+Shift+C.png
Clipboard_ XnViewMP Ctrl+C.png

User avatar
xnview
Author of XnView
Posts: 31798
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Copy and paste selection issues in image view, clipboard is to blame?

Post by xnview » Tue Apr 23, 2019 7:52 am

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.

For GIMP problem, i don't know why
Pierre.

User avatar
xnview
Author of XnView
Posts: 31798
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Copy and paste selection issues in image view, clipboard is to blame?

Post by xnview » Tue Sep 17, 2019 10:23 am

This problem is supposed to be fixed in XnView MP 0.94. Please check and confirm the bug fix here.
Pierre.

Post Reply