Two thumbnail bugs in Browser mode

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
Lee James
Posts: 60
Joined: Sun May 25, 2014 12:47 pm

Two thumbnail bugs in Browser mode

Post by Lee James » Mon Mar 25, 2019 4:03 pm

1.

Problem: It is generating thumbnails for videos, even though I have video thumbnails turned off in "Custom Filter".

Result: If I browse a folder containing videos and pictures, the program freezes while it generates video thumbnails, even though video thumbnails never appear.

Solution: It should never generate video thumbnails if this is turned off in "Custom Filter".

2.

Problem: The program is generating folder thumbnails BEFORE generating thumbnails for the current folder.

Result: If I browse a folder containing 1 sub-folder with 1,000 videos, the program will freeze while it generates thumbnails for the 1,000 videos BEFORE generating thumbnails for the images in the folder I'm viewing.

Solution: XnView should always generate thumbnails for the visible files in the current folder first BEFORE generating folder thumbnails.

Tehbotol
Posts: 17
Joined: Thu Nov 22, 2018 3:28 pm

Re: Two thumbnail bugs in Browser mode

Post by Tehbotol » Fri Apr 12, 2019 12:26 pm

1. could confirm this, disabling the custom filter for thumbnail video did indeed cause the thumbnail not to appear, but it seem it still generating the thumbnail in the background since the progress bar are slow when browsing a folder with a lot of video.

2. agree on this :)

User avatar
xnview
Author of XnView
Posts: 32070
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Two thumbnail bugs in Browser mode

Post by xnview » Mon Apr 15, 2019 1:38 pm

Lee James wrote:
Mon Mar 25, 2019 4:03 pm
Problem: It is generating thumbnails for videos, even though I have video thumbnails turned off in "Custom Filter".
I can't confirm, i have no video thumbnails built if this settings is off. You have perhaps the thumbnails already in the cache?
Problem: The program is generating folder thumbnails BEFORE generating thumbnails for the current folder.
Right
Pierre.

Tehbotol
Posts: 17
Joined: Thu Nov 22, 2018 3:28 pm

Re: Two thumbnail bugs in Browser mode

Post by Tehbotol » Mon Apr 15, 2019 11:21 pm

Okay i just did another test,
video thumbnail turned off in custom filter

Browsing folder with many MKV file, progress bar goes very fast
Browsing folder with many mp4 file, progress bar goes slow

by cache do you mean catalog? if yes then the test with the catalog option turned off
xnview wrote:
Mon Apr 15, 2019 1:38 pm
Lee James wrote:
Mon Mar 25, 2019 4:03 pm
Problem: It is generating thumbnails for videos, even though I have video thumbnails turned off in "Custom Filter".
I can't confirm, i have no video thumbnails built if this settings is off. You have perhaps the thumbnails already in the cache?
Problem: The program is generating folder thumbnails BEFORE generating thumbnails for the current folder.
Right

User avatar
xnview
Author of XnView
Posts: 32070
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Two thumbnail bugs in Browser mode

Post by xnview » Tue Apr 16, 2019 11:40 am

Tehbotol wrote:
Mon Apr 15, 2019 11:21 pm
Browsing folder with many MKV file, progress bar goes very fast
Browsing folder with many mp4 file, progress bar goes slow
ok, you're right, it's a bug
Pierre.

User avatar
xnview
Author of XnView
Posts: 32070
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Two thumbnail bugs in Browser mode

Post by xnview » Tue Sep 17, 2019 10:22 am

This problem is supposed to be fixed in XnView MP 0.94. Please check and confirm the bug fix here.
Pierre.

Tehbotol
Posts: 17
Joined: Thu Nov 22, 2018 3:28 pm

Re: Two thumbnail bugs in Browser mode

Post by Tehbotol » Wed Oct 02, 2019 1:24 pm

thank you for fixing the bug, just tried it and seem the bug is fixed

Post Reply