XnViewMP 0.93 goes 'Not Responding' on Windows 10

*** Please report new bugs here! ***

Moderator: Dreamer

jgh
Posts: 25
Joined: Wed Jul 19, 2017 4:08 pm

XnViewMP 0.93 goes 'Not Responding' on Windows 10

Post by jgh » Sun Mar 03, 2019 4:41 pm

Installed XnViewMP 0.93 to replace 0.92 on Windows 10 (1809 with latest updates), all 64 bit, and while XnViewMP opens ok (to browse folder it last did), and will open a file, doing anything more (zoom image, close image, change to browse a different folder...) causes it to go 'Not Responding'.

XnViewMP installed by running downloaded XnVIewMP Win 64 bit Setup exe file.

Rebooting Windows, and un- and reinstalling XnViewMP, have not had any effect.

User avatar
xnview
Author of XnView
Posts: 31918
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnViewMP 0.93 goes 'Not Responding' on Windows 10

Post by xnview » Mon Mar 04, 2019 6:57 am

and no problem with 0.92? the opened folder contains only images?
Pierre.

jgh
Posts: 25
Joined: Wed Jul 19, 2017 4:08 pm

Re: XnViewMP 0.93 goes 'Not Responding' on Windows 10

Post by jgh » Wed Mar 06, 2019 4:47 pm

Don't recall having the problem under 0.92 (which has gone from W10 system) - I'm sure I would if I had had it. (And I don't have it on a similar folder using Version 0.91 beta 4 64bits (Jul 17 2018) on W7, if that's any help)

No, the opened folder is not just images - it's my Downloads folder (on my W10 system), so 314 files of all sorts and types.

Having a look at what's in the browser, two things I note (1) while most (or at least many) files have a 'large' icon (filling the space in browser grid), which for images is a thumbnail of the image, some (including some images) have only a small file type icon; and (2) some files are not listed, notably pdfs (there may be others).

(Random unrelated thought out loud: should XnView be listing all files, or only those it can handle?)

User avatar
xnview
Author of XnView
Posts: 31918
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnViewMP 0.93 goes 'Not Responding' on Windows 10

Post by xnview » Thu Mar 07, 2019 1:17 pm

you have perhaps a file in Download folder that locks XnView
Pierre.

jgh
Posts: 25
Joined: Wed Jul 19, 2017 4:08 pm

Re: XnViewMP 0.93 goes 'Not Responding' on Windows 10

Post by jgh » Thu Mar 07, 2019 2:31 pm

Possibly - that would certainly explain it. In which case I would expect some kind of error/warning message, rather than XnView just hanging.

How can I tell whether this is the case, and if so, which file it is?

User avatar
xnview
Author of XnView
Posts: 31918
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnViewMP 0.93 goes 'Not Responding' on Windows 10

Post by xnview » Sun Mar 10, 2019 6:14 pm

jgh wrote:
Thu Mar 07, 2019 2:31 pm
How can I tell whether this is the case, and if so, which file it is?
you can't see during the thumbnail creation process on which file it locks?
Pierre.

jgh
Posts: 25
Joined: Wed Jul 19, 2017 4:08 pm

Re: XnViewMP 0.93 goes 'Not Responding' on Windows 10

Post by jgh » Tue Mar 12, 2019 11:49 pm

No - it builds the browser grid of thumbnails, without any apparent problem - although not terribly quickly (but this may be my PC being a bit slow), it's only when I look carefully that I realise that there are some (no idea how many) missing, including seemingly all the pdfs (but many non-image files are there). Also I notice some image (and other) files have a small file type icon rather than a proper thumbnail.

User avatar
xnview
Author of XnView
Posts: 31918
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnViewMP 0.93 goes 'Not Responding' on Windows 10

Post by xnview » Wed Mar 13, 2019 6:29 am

if you try to move non images files in another folder?
Pierre.

jgh
Posts: 25
Joined: Wed Jul 19, 2017 4:08 pm

Re: XnViewMP 0.93 goes 'Not Responding' on Windows 10

Post by jgh » Tue Mar 19, 2019 11:09 am

Apologies for delay in responding, I've been away.

I tried moving the pdf files to their own sub-folder, but without much joy - XnView still goes not responding, but maybe not quite so quickly. Don't know if there are other problematic files in that folder.

But I would say that - if XnView is to offer a 'browse folder' function, then it needs to be able - one way or another all the files in that folder, either by processing them (successfully, whatever that might mean - maybe just putting some kind of can't really process this file indication), or, if it can't deal with them (because it doesn't have the necessary sub-routine, they're the wrong sort of file, or broken) ignoring them.

User avatar
xnview
Author of XnView
Posts: 31918
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnViewMP 0.93 goes 'Not Responding' on Windows 10

Post by xnview » Tue Mar 19, 2019 3:35 pm

jgh wrote:
Tue Mar 19, 2019 11:09 am
But I would say that - if XnView is to offer a 'browse folder' function, then it needs to be able - one way or another all the files in that folder, either by processing them (successfully, whatever that might mean - maybe just putting some kind of can't really process this file indication), or, if it can't deal with them (because it doesn't have the necessary sub-routine, they're the wrong sort of file, or broken) ignoring them.
yes, but in your case, there is a file that locks XnView, is it possible to find it?
Pierre.

jgh
Posts: 25
Joined: Wed Jul 19, 2017 4:08 pm

Re: XnViewMP 0.93 goes 'Not Responding' on Windows 10

Post by jgh » Tue Mar 26, 2019 12:40 pm

xnview wrote:
Tue Mar 19, 2019 3:35 pm
yes, but in your case, there is a file that locks XnView, is it possible to find it?
Not easily, when you have several hundred assorted files in the folder (and sub-folders), and no indication of which it might be: that is I suspect the reason for https://newsgroup.xnview.com/viewtopic.php?f=82&t=38757 - if there was an error log we would have somewhere to start, rather than it being a matter of looking for needle in haystack...

Please note that I regard this as a 'must fix' issue: if such file is in the 'opening' folder on launching XnView, then XnView will always hang and be unusable as long as the - unidentifiable - file is in that folder. And that folder will stay the 'opening' folder...

But having finally had a chance to play around, and rearrange the folder structure, have tracked it down to being a problem with some (not all) powerpoint files.

I managed to isolate two folders:
One did not have problem, and has 2 .ppt files, and 2 .pptx files. On going into this in the browser, on the browser grid all four pop up, then the two .pptx files go, giving thumbnails for the two .ppt files. On selecting these I get a 'multi page' view, one page for each image in the .ppt file - not each ppt page, (but none of the wording, etc that is in the file). Note: one (but not the other) .pptx files contains images.

The other - with a similar set of .ppt/.pptx files, don't know what the difference is - does have the problem - on going into it in the browser, I just see icons and XnView hangs.
If - in the the browser - I go to the folder containing this folder, I also get the problem. That (problematic) folder, and subsequent folders, show as icons, not thumbnails (with or without image thumbnails).

After XnView hangs, and I force it to close, on trying to move problem folder (or file), I cannot, as 'file is still open in programme' (sometimes identified as XnView MP). Need to restart Windows to clear this (and 'Program Manager' hinders the shutdown).

Note: all the powerpoints open ok, both with Powerpoint Viewer, and Libre Office Impress. I don't know how they were created.
On other systems I've tried, on going to a Powerpoint file in XnView (different version), it has been opened externally by Powerpoint Viewer or Libre Office Impress.

User avatar
xnview
Author of XnView
Posts: 31918
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnViewMP 0.93 goes 'Not Responding' on Windows 10

Post by xnview » Tue Mar 26, 2019 4:00 pm

jgh wrote:
Tue Mar 26, 2019 12:40 pm
The other - with a similar set of .ppt/.pptx files, don't know what the difference is - does have the problem - on going into it in the browser, I just see icons and XnView hangs.
If - in the the browser - I go to the folder containing this folder, I also get the problem. That (problematic) folder, and subsequent folders, show as icons, not thumbnails (with or without image thumbnails).
is it possible to have this folder?
Pierre.

jgh
Posts: 25
Joined: Wed Jul 19, 2017 4:08 pm

Re: XnViewMP 0.93 goes 'Not Responding' on Windows 10

Post by jgh » Tue Mar 26, 2019 5:20 pm

Yes - sent by by e-mail.

User avatar
xnview
Author of XnView
Posts: 31918
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnViewMP 0.93 goes 'Not Responding' on Windows 10

Post by xnview » Wed Mar 27, 2019 2:56 pm

thanks, i can reproduce and fix
Pierre.

jgh
Posts: 25
Joined: Wed Jul 19, 2017 4:08 pm

Re: XnViewMP 0.93 goes 'Not Responding' on Windows 10

Post by jgh » Mon May 06, 2019 7:45 pm

Over a month later, any progress/likely date for fix on this?

Post Reply