Unusable for videos?

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

Lewis
Posts: 3
Joined: Sat Mar 02, 2024 11:37 am

Unusable for videos?

Post by Lewis »

Whenever I navigate to a video, it's a 50% chance that Xnview MP freezes and I have to force close it.

Is anyone having success playing videos without freezes, glitches or crashes?

Here is a sample for you to try. Just a folder with a jpg and a mp4 video file. Try to open the jpg and then navigate to the video back and forth (with arrow keys or scroll wheel), with "Auto play (video)" enabled.
For me it freezes 9 out of 10 times and I have to force close XnView MP. I tried this on another Windows PC, same thing.

I usually use MPV for playing videos and it never ever freezes with any video file. Couldn't XnView MP include the MPV playback engine to solve this?

Also, it looks like GPU hardware decoding is enabled in XnView MP, which might explain some of these problems. Is there a way to disable it, to see if the situation improves?
User avatar
xnview
Author of XnView
Posts: 43833
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Unusable for videos?

Post by xnview »

with latest version? Windows?
Pierre.
Lewis
Posts: 3
Joined: Sat Mar 02, 2024 11:37 am

Re: Unusable for videos?

Post by Lewis »

Yes, latest version on Windows.

Can GPU-accelerated video decoding be disabled?
User avatar
xnview
Author of XnView
Posts: 43833
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Unusable for videos?

Post by xnview »

ok, i can reproduce
Pierre.
User avatar
xnview
Author of XnView
Posts: 43833
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Unusable for videos?

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
Lewis
Posts: 3
Joined: Sat Mar 02, 2024 11:37 am

Re: Unusable for videos?

Post by Lewis »

That's great. I'm looking forward to testing the new version.

But excuse me if I insist on the ability to disable GPU acceleration. And not just for this problem, but I usually find that CPU decoding works better.
User avatar
xnview
Author of XnView
Posts: 43833
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Unusable for videos?

Post by xnview »

This problem is supposed to be fixed in XnView MP 1.7.0. Please check and confirm the bug fix here.
Pierre.