1.6.4 Serious color coding bug in the Export function

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

Kadet
Posts: 111
Joined: Thu Oct 20, 2022 7:23 pm

1.6.4 Serious color coding bug in the Export function

Post by Kadet »

[1.6.4] Win 11 - 64 bits

I just discovered a serious bug when using the Export function. This doesn't always happen, but when it does, it is noticeable.
_TEST_FILE - exporting_.png
As you can see in the image on the right, the colors are paler than the original on the left. When I press the 'Export' button, these broken colors are saved in file on the disk. The output format does not matter.
Everything is fine when I use the 'Save as' function.

Here's an image for testing:
_TEST_FILE_.png
Please fix it ASAP.

Edit:
It's happens when ICC profile is ON.
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43833
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.6.4 Serious color coding bug in the Export function

Post by xnview »

could you send me the ouput file? What do you have in 'settings>Color profile'?
Pierre.
Kadet
Posts: 111
Joined: Thu Oct 20, 2022 7:23 pm

Re: 1.6.4 Serious color coding bug in the Export function

Post by Kadet »

I make few tests more.

On/Off profile ICC has no effect on saving.

Saving is affected by the 'keep ICC' option. IF is ON in 'save as' function ICC profile is saving to file, but is not saving in Export function and we have wrong picture. IF is OFF in both file we have bugged image.

Output file:
_TEST_FILE - EXPORT_.png
[Load]
...
ICCIntent=1
ICCProfile=
useSystemICC=true
ICCRGBDefault=1
ICCRGBDefaultProfile=
ICCCMYKDefault=1
ICCCMYKDefaultProfile=

[Save]
addExtensionIfNeeded=true
keepOriginalDate=true
keepEXIF=false
keepIPTC=false
keepXMP=false
keepICC=true
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43833
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.6.4 Serious color coding bug in the Export function

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 43833
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.6.4 Serious color coding bug in the Export function

Post by xnview »

This problem is supposed to be fixed in XnView MP 1.6.5. Please check and confirm the bug fix here.
Pierre.
Kadet
Posts: 111
Joined: Thu Oct 20, 2022 7:23 pm

Re: 1.6.4 Serious color coding bug in the Export function

Post by Kadet »

Problem is resolved in half.

Still bug is when I export file to JPG, JPEG-XL, JPEG-XR, JPEG-2000

This is interesting, that when I use the "Save as" function and save a JPG file, and then I use export to JPG, the ICC is saved during export.

I also see something else, that ICC is not saved for JPEG-XL also with the "Save as" function.
Last edited by Kadet on Thu Feb 22, 2024 4:06 pm, edited 1 time in total.
User avatar
xnview
Author of XnView
Posts: 43833
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.6.4 Serious color coding bug in the Export function

Post by xnview »

Currently ICC profile is not supported for JPEG-XL, JPEG-XR, JPEG-2000 output
Pierre.