1.6.x regression: copy image with ICC to clipboard no longer convert color properly

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

fireattack
Posts: 90
Joined: Sun Nov 10, 2013 8:02 am

1.6.x regression: copy image with ICC to clipboard no longer convert color properly

Post by fireattack »

STR:

0. In settings -> General -> ICC, Use ICC
1. Prepare an image with embedded ICC. I attached one for your convenience.
2. Open the image with XnView MP (viewer).
3. Press Ctrl+C or Ctrl+shift+C to copy the image to clipboard.
4. Open Paint, press ctrl+V to paste the image.

Expected, and worked like so in 1.4.5:
The copied image has the same color as the original one shown in XnView -- the colors are converted to sRGB with same perceptual color.

Observed in 1.6.x:
The copied image in Paint has their perceptual color and becomes pale -- because it does not account for the ICC and just shows the RGB value as they're sRGB.
You do not have the required permissions to view the files attached to this post.
fireattack
Posts: 90
Joined: Sun Nov 10, 2013 8:02 am

Re: 1.6.x regression: copy image with ICC to clipboard no longer convert color properly

Post by fireattack »

A screenshot to show the bug.
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43833
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.6.x regression: copy image with ICC to clipboard no longer convert color properly

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 43833
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.6.x regression: copy image with ICC to clipboard no longer convert color properly

Post by xnview »

This problem is supposed to be fixed in XnView MP 1.6.5. Please check and confirm the bug fix here.
Pierre.