MP 1.6.1: Cannot delete on SMB.

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

tenpaMk2
Posts: 7
Joined: Sat Oct 21, 2023 6:33 am

MP 1.6.1: Cannot delete on SMB.

Post by tenpaMk2 »

XnView: MP 1.6.1 - 64 bit
OS: Mac - 64bit

I cannot delete file on SMB directory.

When I try to delete it, confirmation window is pop up. the message is the below.
> Are you sure to delete these 1 item(s)?

Then, I select Yes. But, the file is remain.

This problem is occur only in SMB directory (ex: Synology NAS).
I can delete images in non-SMB directory.

To reproduce:
1. Delete file.

Actual behaviour (bug):
The images still remained after deleting in SMB directory.
:bug:

Expected behaviour:
The images are deleted after deleting in SMB directory.

Thank you developers❗
tenpaMk2
Posts: 7
Joined: Sat Oct 21, 2023 6:33 am

Re: MP 1.6.1: Cannot delete on SMB.

Post by tenpaMk2 »

I have done more tests.
  • MP 1.5.5: Can delete
  • MP 1.6.0: Cannot delete
  • MP 1.6.1: Cannot delete
So, I think there is a bug in change of 1.6.0.
User avatar
xnview
Author of XnView
Posts: 43098
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: MP 1.6.1: Cannot delete on SMB.

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
tenpaMk2
Posts: 7
Joined: Sat Oct 21, 2023 6:33 am

Re: MP 1.6.1: Cannot delete on SMB.

Post by tenpaMk2 »

Thank you for your quick fix❗
User avatar
xnview
Author of XnView
Posts: 43098
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: MP 1.6.1: Cannot delete on SMB.

Post by xnview »

This problem is supposed to be fixed in XnView MP 1.6.2. Please check and confirm the bug fix here.
Pierre.