1.5.5: Filter by unrated does not work

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

refcode
Posts: 2
Joined: Wed Oct 11, 2023 5:10 pm

1.5.5: Filter by unrated does not work

Post by refcode »

XnView: MP 1.5.5 - 64 bit
OS: Linux - 64bit

The new rating filter visual functions for 1-5 and <=, >=, = just fine. However, selecting the empty star clears the filter rather than filtering by "unrated" (so = and empty star shows all ratings).

Effect: Cannot filter by unrated images.

To reproduce:
1. Open a directory with some unrated and some rated images.
2. Set image rating filter operand to '='
3. Set image rating filter star to 0 (click empty star on left)

Actual behaviour (bug): filters by all images of any rating

Expected behaviour: filter to only unrated images

Thanks! Been using MP for years, love the software but this functionality seems to have broken between versions.
refcode
Posts: 2
Joined: Wed Oct 11, 2023 5:10 pm

Re: 1.5.5: Filter by unrated does not work

Post by refcode »

Note that using the Search function and selecting Rating > Equal To > Unrated also pulls up no results. If it's relevant, I have XMP sidecars enabled and ratings get dumped to there along with categories and other metadata.
User avatar
xnview
Author of XnView
Posts: 43098
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.5.5: Filter by unrated does not work

Post by xnview »

Pierre.
User avatar
xnview
Author of XnView
Posts: 43098
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.5.5: Filter by unrated does not work

Post by xnview »

This problem is supposed to be fixed in XnView MP 1.6.0. Please check and confirm the bug fix here.
Pierre.