Can not delete folder in version 0.99.1 for MacOS

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

User avatar
xnview
Author of XnView
Posts: 43094
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Can not delete folder in version 0.99.1 for MacOS

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce, for files it works but not for folder
Pierre.
mofli
Posts: 1
Joined: Fri Apr 07, 2023 12:35 am

Re: Can not delete folder in version 0.99.1 for MacOS

Post by mofli »

Hello everyone,

I am experiencing the same issue as described by diusonem on March 16th. I am using MacOS 13.2.1 and the latest XnView MP version 1.4.3 64bits (Feb 25 2023). When trying to delete a folder from an external disk using XnView MP, the folder seems to be deleted in the application, but it still exists in Finder.

I have tried different external hard drives with various models, and the issue persists across all of them. The file system format of my external hard drives is exFAT. I have confirmed that the system access permissions are properly set. Interestingly, this issue only occurs on external disks and not on my local disk.

I have also attempted the suggestions mentioned earlier in this thread, such as checking and updating the application's access permissions to the external disk, but the problem remains. It seems to be a bug in XnView MP's folder deletion on MacOS, even in the latest version 1.4.3.

I wanted to bring this to the attention of the developers and the community, and I am wondering if there has been any progress or updates regarding this issue? Any help or suggestions would be greatly appreciated.

Thank you!
User avatar
xnview
Author of XnView
Posts: 43094
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Can not delete folder in version 0.99.1 for MacOS

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 43094
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Can not delete folder in version 0.99.1 for MacOS

Post by xnview »

This problem is supposed to be fixed in XnView MP 1.6.0. Please check and confirm the bug fix here.
Pierre.
marshalleq
Posts: 1
Joined: Fri Oct 27, 2023 12:12 am

Re: Can not delete folder in version 0.99.1 for MacOS

Post by marshalleq »

Something similar is happening on version 1.6.1 on linux. I delete a folder and it won't delete, even though I created it within the XNView application. Some other interesting behaviour though is in that the XNView software does not necessarily match in it's display what is on the disk - and it's not a permissions issue. New folders on one side don't turn up - even with a refresh or a restart and vice versa. This worked on Windows quite well, but not on linux. Not sure what's going on.
User avatar
xnview
Author of XnView
Posts: 43094
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Can not delete folder in version 0.99.1 for MacOS

Post by xnview »

marshalleq wrote: Fri Oct 27, 2023 12:30 am Something similar is happening on version 1.6.1 on linux. I delete a folder and it won't delete, even though I created it within the XNView application. Some other interesting behaviour though is in that the XNView software does not necessarily match in it's display what is on the disk - and it's not a permissions issue. New folders on one side don't turn up - even with a refresh or a restart and vice versa. This worked on Windows quite well, but not on linux. Not sure what's going on.
I can't reproduce on linux, is it a extfs drive?
Pierre.