Encoding (?) problem with accented keywords in IPTC-IIM tab

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

KLE-France
Posts: 23
Joined: Mon Jan 14, 2019 3:00 pm

Encoding (?) problem with accented keywords in IPTC-IIM tab

Post by KLE-France »

Bonjour,

There seems to be an encoding (?) issue with accented keywords in the IPTC-IIM tab of the Info Pane.

I'm on Windows 10 Home and using XNView MP Version 0.98.4 64bits (May 28 2021).

All keywords are entered using the Edit IPTC-IIM window.

For example, the word "Clément" displays as "Clément" in the IPTC-IIM tab, "Gîte" as "Gîte", "Uzès" as "Uzès", etc. etc.

This makes it impossible to search for images using the "IPTC:Keywords" function IF the right spelling is used (e.g., "Uzès"). However, the search does work if the messed up spelling is used (e.g., "Uzès").

Note that this has no effect on the Category Filter tab, where the keywords appear correctly and clicking them finds the right images.

Note too that the keywords appear correctly in the Right-Click>Properties>Details>Tags dialog of the file itself.

This problem is new, although I can't say what version it dates back to. All I can say is that in the relatively recent past, I could search accented keywords (so I suppose they were encoded correctly); now I can't (so pure speculation would suggest that the problem dates to this version, maybe the version before that, but certainly not any further than that).

Thanks in advance and happy shooting!
User avatar
xnview
Author of XnView
Posts: 36389
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Encoding (?) problem with accented keywords in IPTC-IIM tab

Post by xnview »

Do you have tried to change settings>Metadata>Encoding?
Pierre.
KLE-France
Posts: 23
Joined: Mon Jan 14, 2019 3:00 pm

Re: Encoding (?) problem with accented keywords in IPTC-IIM tab

Post by KLE-France »

Bonjour Pierre,
Do you have tried to change settings>Metadata>Encoding?

I didn't change anything there (I hadn't even noticed it existed). Looks like this currently:

Settings_Metadata_Encoding.jpg
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 36389
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Encoding (?) problem with accented keywords in IPTC-IIM tab

Post by xnview »

could you send me a sample file?
Pierre.
KLE-France
Posts: 23
Joined: Mon Jan 14, 2019 3:00 pm

Re: Encoding (?) problem with accented keywords in IPTC-IIM tab

Post by KLE-France »

Désolé pour mes réponses à vitesse escargot.

Here's a photo with "Uzès" as a keyword:

Uzès visage.jpg

Let me know if I need to send it to you in some other way.
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 36389
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Encoding (?) problem with accented keywords in IPTC-IIM tab

Post by xnview »

il faut choisir 'utf8'
Pierre.
User avatar
xnview
Author of XnView
Posts: 36389
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Encoding (?) problem with accented keywords in IPTC-IIM tab

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
KLE-France
Posts: 23
Joined: Mon Jan 14, 2019 3:00 pm

Re: Encoding (?) problem with accented keywords in IPTC-IIM tab

Post by KLE-France »

il faut choisir 'utf8'

So for those who may come to this post in the future, Pierre is saying to choose 'UTF-8' from the dropdown menu at Tools/Settings.../Metadata/Encoding/IPTC.


Looks like this:

Choisir utf8.jpg


This did indeed resolve the problem I described above.


If I may, I would add two follow-up questions:

1) Would it be better to have this set as default (or is it the default and I changed something without noticing?)?

2) Would it be better to choose UTF-8 at "Embedded comment" as well?


No, sorry, I wasn't paying attention: your second post there is saying that you fixed the issue for version 98.5. Thank you!



En tout cas, merci encore pour votre disponibilité ici dans les forums!
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 36389
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Encoding (?) problem with accented keywords in IPTC-IIM tab

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.99.0. Please check and confirm the bug fix here.
Pierre.