Wrong video orientation

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderators: XnTriq, helmut, xnview, Dreamer

User avatar
xnview
Author of XnView
Posts: 43611
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Wrong video orientation

Post by xnview »

This problem is supposed to be fixed in XnView MP 1.01. Please check and confirm the bug fix here.
Pierre.
User avatar
B.Douille
Posts: 259
Joined: Sat Sep 09, 2006 9:25 pm
Location: Hte Savoie - France

Re: Wrong video orientation

Post by B.Douille »

(message cancelled)
Last edited by B.Douille on Sat Sep 24, 2022 5:03 pm, edited 1 time in total.
Daniel, promoting XnView since 2004, moved to MP (exclusively) years ago (Platform Windows and Linux Ubuntu)
User avatar
B.Douille
Posts: 259
Joined: Sat Sep 09, 2006 9:25 pm
Location: Hte Savoie - France

Re: Wrong video orientation

Post by B.Douille »

xnview wrote: Tue Aug 16, 2022 10:16 am This problem is supposed to be fixed in XnView MP 1.01. Please check and confirm the bug fix here.
Not fixed yet (reproduced in Version 1.3 64bits (Sep 6 2022))

note: I checked my .ini file and can confirm entry useInternalVideoPlayer=false

PS: I see there is a similar issue "Video thumbnail rotation" possibly due to the delay to get the metadata / need to go through a number of frames before accessing them.
Daniel, promoting XnView since 2004, moved to MP (exclusively) years ago (Platform Windows and Linux Ubuntu)
User avatar
B.Douille
Posts: 259
Joined: Sat Sep 09, 2006 9:25 pm
Location: Hte Savoie - France

Re: Wrong video orientation

Post by B.Douille »

Hello Pierre,

I can confirm the bug is still in version 1.5.3
(Windows 7, ini file includes "useInternalVideoPlayer=false", EXIF metadata shows "Rotation : 90").
I don't use to take videos in portrait mode but it happens from time to time.
Daniel, promoting XnView since 2004, moved to MP (exclusively) years ago (Platform Windows and Linux Ubuntu)