XnView MP 0.90 Rotate Bug

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: XnView MP 0.90 Rotate Bug

Post by xnview »

obelisk wrote: Thu Jul 15, 2021 1:01 am Sent you.
Also if you batch convert, the output will be UPSIDE DOWN!
I don't know how many times you're applying the rotate from the xmp file.
ok, i can reproduce. if you have an orientation field in EXIF or XMP, it will be used. you need to uncheck 'Settings>General>Rotate images...'
Pierre.
obelisk
Posts: 424
Joined: Fri Jan 09, 2009 9:54 am

Re: XnView MP 0.90 Rotate Bug

Post by obelisk »

Is it considered a bug?
Will it be fixed?
I reverted to 0.87 it's not usable.
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: XnView MP 0.90 Rotate Bug

Post by xnview »

obelisk wrote: Thu Jul 15, 2021 9:16 am Is it considered a bug?
Will it be fixed?
I reverted to 0.87 it's not usable.
It's not a bug, you don't want to uncheck the setting?
Pierre.
obelisk
Posts: 424
Joined: Fri Jan 09, 2009 9:54 am

Re: XnView MP 0.90 Rotate Bug

Post by obelisk »

Of course not. If you turn it off, my file will NOT be rotated at all. Also wrong.

Why do you think this is acceptable? You are showing files in this direction

Thumbnail: ⬆
Image view: ⬅
Batch converted file Thumbnail: ⬇
Batch converted file view: ⬇

XNVIEW is disagreeing with itself in 3 ways. No other viewer in the world is agreeing with XNVIEW. How is it not a bug? You made an explicit change after 0.87. Why? There must be a reason.


RAW/TIF/JPG are rotated differently. You're applying XMP to all, they won't match.
XMP specifies that it applies to RAW file, you're applying to JPG.
XMP is not EXIF.


Everyone that uses LR exports their RAWs as TIF/JPG to the same folder. This affects Every photographer. If you've not heard of this, that means NO photographer is using anything newer than 0.87.


If you really insist, make a setting called
"Do not apply XMP rotation tag to files not specified in XMP file"
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: XnView MP 0.90 Rotate Bug

Post by xnview »

obelisk wrote: Thu Jul 15, 2021 12:18 pm
RAW/TIF/JPG are rotated differently. You're applying XMP to all, they won't match.
XMP specifies that it applies to RAW file, you're applying to JPG.
XMP is not EXIF.
No, xmp sidecar can be applied to JPEG or any file
If you really insist, make a setting called
"Do not apply XMP rotation tag to files not specified in XMP file"
But there is a bug if jpeg/xmp is companion of raw, in this case xmp must not be applied to jpeg
Pierre.
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: XnView MP 0.90 Rotate Bug

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: XnView MP 0.90 Rotate Bug

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.99.0. Please check and confirm the bug fix here.
Pierre.
John_Matthews
Posts: 14
Joined: Wed Oct 27, 2021 3:27 am

Re: XnView MP 0.90 Rotate Bug

Post by John_Matthews »

I'm still having a problem with output rotation in a batch convert. My RAW Olympus E-M1 mark ii (.ORF) portrait photos are not rotating on batch convert to jpg. Not sure why. The photo displays fine everywhere EXCEPT on batch export (finder, inside xnview, etc.). I'm currently running the latest version of .99.1 on a M1 iMac in Big Sur. I've attached screenshots for you to see. Is this still a bug? What can I try (I have thousands of photos)?
You do not have the required permissions to view the files attached to this post.
John_Matthews
Posts: 14
Joined: Wed Oct 27, 2021 3:27 am

Re: XnView MP 0.90 Rotate Bug

Post by John_Matthews »

After more research, it would seem ALL ".ORF" files (from Em1 ii, E-PL9, and E-P7 tested) batch export wrong when photo was taken in portrait. When converted to ".DNG" before export, they do fine. Is there some way to add this support?
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: XnView MP 0.90 Rotate Bug

Post by xnview »

John_Matthews wrote: Wed Oct 27, 2021 5:32 am I'm still having a problem with output rotation in a batch convert. My RAW Olympus E-M1 mark ii (.ORF) portrait photos are not rotating on batch convert to jpg. Not sure why. The photo displays fine everywhere EXCEPT on batch export (finder, inside xnview, etc.). I'm currently running the latest version of .99.1 on a M1 iMac in Big Sur. I've attached screenshots for you to see. Is this still a bug? What can I try (I have thousands of photos)?
It's a known issue, will be fixed
Pierre.
John_Matthews
Posts: 14
Joined: Wed Oct 27, 2021 3:27 am

Re: XnView MP 0.90 Rotate Bug

Post by John_Matthews »

Thank you Pierre for getting back to me. I've found a workaround by exporting the portrait ".ORF" files separately and then making a preset to rotate them... not ideal in that some end up upside-down. Thank you for your help. I love this program as it's just so powerful and unique.
obelisk
Posts: 424
Joined: Fri Jan 09, 2009 9:54 am

Re: XnView MP 0.90 Rotate Bug

Post by obelisk »

Hi, what is the current working way in 0.90.1?
I found with the fix there were some files that are fixed. Then some that worked before but now are rotated wrong.

I can't tell the difference between the xmp files causing the rotate.
In all cases there is .nef .jpg .xmp in the same folder.
obelisk
Posts: 424
Joined: Fri Jan 09, 2009 9:54 am

Re: XnView MP 0.90 Rotate Bug

Post by obelisk »

I also wonder if this depends on the source camera of the file? Would it make a difference how they encode rotate etc?
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: XnView MP 0.90 Rotate Bug

Post by xnview »

obelisk wrote: Mon Nov 22, 2021 10:22 pm I also wonder if this depends on the source camera of the file? Would it make a difference how they encode rotate etc?
could you send me files with problem?
Pierre.
obelisk
Posts: 424
Joined: Fri Jan 09, 2009 9:54 am

Re: XnView MP 0.90 Rotate Bug

Post by obelisk »

I sent you a msg