0.79: Parent category not set from toolbar

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
bgoodman
Posts: 11
Joined: Fri Jun 03, 2016 1:23 am

0.79: Parent category not set from toolbar

Post by bgoodman » Fri Jun 03, 2016 1:32 am

Using XnView MP 0.79 x64 on both Windows 7 and Linux Mint 17.3.

In Settings>Metadata>Automatically apply parent keyword = checked

Select an image and use Category icon in the main toolbar to set a second-level category.

The second level category for the image is set, but the parent category is not.

[Expected both parent and second-level category to be set.]

Parent category IS set if second-level category is clicked in Categories panel.

User avatar
helmut
Posts: 8145
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Parent category not set from toolbar

Post by helmut » Thu Feb 23, 2017 10:25 pm

Works fine for me in v0.84: Both assigning via toolbar icon and context menu "Category »".
Could you please try and confirm, bgoodman?

Though, when dragging and dropping the parent categories are not assigned. I'm not metadata expert (yet) but I'd consider this as a bug.

User avatar
m.Th.
XnThusiast
Posts: 1491
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: Parent category not set from toolbar

Post by m.Th. » Fri Feb 24, 2017 5:26 pm

helmut wrote:Works fine for me in v0.84: Both assigning via toolbar icon and context menu "Category »".
Could you please try and confirm, bgoodman?

Though, when dragging and dropping the parent categories are not assigned. I'm not metadata expert (yet) but I'd consider this as a bug.
The program behavior should be consistent regardless of GUI metaphor which triggered this behavior.

If the users think that 'it is the same action' then the program must execute the same action.
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

User avatar
helmut
Posts: 8145
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Parent category not set from toolbar

Post by helmut » Fri Feb 24, 2017 7:19 pm

m.Th. wrote:..The program behavior should be consistent regardless of GUI metaphor which triggered this behavior.

If the users think that 'it is the same action' then the program must execute the same action.
If I understand right, you (m.Th.) consider this also as a bug.

:arrow: Reproduced

User avatar
m.Th.
XnThusiast
Posts: 1491
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: Parent category not set from toolbar

Post by m.Th. » Sat Feb 25, 2017 7:22 am

helmut wrote:
m.Th. wrote:..The program behavior should be consistent regardless of GUI metaphor which triggered this behavior.

If the users think that 'it is the same action' then the program must execute the same action.
If I understand right, you (m.Th.) consider this also as a bug.

:arrow: Reproduced
yes
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

User avatar
xnview
Author of XnView
Posts: 30094
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.79: Parent category not set from toolbar

Post by xnview » Sat Jul 08, 2017 1:04 pm

This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.
Pierre.

Post Reply