1.6.4: "View">"Use sharpen" causes the impossibility of viewing GIF/WEBP/PNG/JXL-animation

Bugs which have been reproduced by a second user or the developer, or features to do

Moderators: XnTriq, helmut, xnview, Dreamer

adrem85
Posts: 50
Joined: Mon Feb 10, 2020 12:47 pm

1.6.4: "View">"Use sharpen" causes the impossibility of viewing GIF/WEBP/PNG/JXL-animation

Post by adrem85 »

"View">"Use sharpen" causes the impossibility of viewing GIF-animation:

https://www.upload.ee/files/16290673/Us ... n.mp4.html

The bug was found on version 1.6.4, but it was quite possible that it was in earlier versions.

XnViewMP 1.6.4 x64 portable. Windows 11.

NB - Important condition: there must be other files (JPG/PNG/WEBP) in the folder with the animation file. The failure occurs precisely when viewing files sequentially in a folder with such a set of files at the moment of transition from a regular file to an animated one.
Last edited by adrem85 on Sun Feb 18, 2024 11:30 am, edited 4 times in total.
User avatar
user0
XnThusiast
Posts: 1589
Joined: Sat May 09, 2015 9:37 am

Re: 1.6.4: "View">"Use sharpen" causes the impossibility of viewing GIF-animation

Post by user0 »

I don't have this problem with my gif files.
It would be helpful if you share your .gif and .ini.
adrem85
Posts: 50
Joined: Mon Feb 10, 2020 12:47 pm

Re: 1.6.4: "View">"Use sharpen" causes the impossibility of viewing GIF-animation

Post by adrem85 »

user0 wrote: Sun Feb 18, 2024 5:40 am I don't have this problem with my gif files.
I would like to clarify - do you have the same version of the program and OS?
user0 wrote: Sun Feb 18, 2024 5:40 amIt would be helpful if you share your .gif
Any GIF animation doesn’t work for me, it’s not a matter of a specific file.
user0 wrote: Sun Feb 18, 2024 5:40 amand .ini
The version of the INI file corruption is quite logical, but the fact is that I double-checked it on XnViewMP 1.6.4 Portable, which I had just downloaded from the website - and there, on a completely new, just created INI with standard settings, the GIF animation does not work for me exactly just like on my old INI...

Moreover, I have now found out that when I turn on the “Use Sharpen” parameter, not only GIF animation does not work, but also any animation that the program supports - GIF, WEBP, JPG-XL, PNG.

NB - Important condition: there must be other files (JPG/PNG/WEBP) in the folder with the animation file. The failure occurs precisely when viewing files sequentially in a folder with such a set of files at the moment of transition from a regular file to an animated one.
User avatar
user0
XnThusiast
Posts: 1589
Joined: Sat May 09, 2015 9:37 am

Re: 1.6.4: "View">"Use sharpen" causes the impossibility of viewing GIF/WEBP/PNG/JXL-animation

Post by user0 »

adrem85 wrote: Sat Feb 17, 2024 11:30 pm NB - Important condition: there must be other files (JPG/PNG/WEBP) in the folder with the animation file. The failure occurs precisely when viewing files sequentially in a folder with such a set of files at the moment of transition from a regular file to an animated one.
can confirm the issue
User avatar
xnview
Author of XnView
Posts: 43700
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.6.4: "View">"Use sharpen" causes the impossibility of viewing GIF/WEBP/PNG/JXL-animation

Post by xnview »

:bugconfirmed:
Pierre.
adrem85
Posts: 50
Joined: Mon Feb 10, 2020 12:47 pm

Re: 1.6.4: "View">"Use sharpen" causes the impossibility of viewing GIF/WEBP/PNG/JXL-animation

Post by adrem85 »

I apologize for my long absence.

Unfortunately, the problem is not solved, everything still happens as shown in my first video. Only turning off the "View">"Use sharpen" option in Settings helps.

NB: for testing you should make sure to have also regular images (JPG, PNG etc) in the folder together with the animation file.

v1.7.0.