Error when zooming into a photo in Preview Area

Bugs which have been reproduced by a second user or the developer, or features to do

Moderators: XnTriq, helmut, xnview, Dreamer

LuNik
Posts: 13
Joined: Thu Aug 04, 2022 8:24 am

Error when zooming into a photo in Preview Area

Post by LuNik »

Hi,
I can notice a strange behavior when I zoom into a photo in the preview area.
Up to a magnification of 100% the center point of the photo keeps more or less the same. Of cause there is a change between a magnification where the complete photo is visible and a magnification where only a part of the photo can be shown in the preview area.
At a magnification of 142% there is a significant change and only a little part of the photo is visible any more, looks like the photo is shifted to the upper left corner. Increasing the magnification further the photo is shown with the same center point as before. Generally it seems that the center point for the magnification is depending on the mouse position ...
Hope I could describe this in an understandable way.

This behavior might depend on the monitor resolution??? I use a 4k monitor at a resolution of 3840 x 2160.

Could you please check this?!? At least for me the critical magnificationm is 142%!

Best regards
Ludger
LuNik
Posts: 13
Joined: Thu Aug 04, 2022 8:24 am

Re: Error when zooming into a photo in Preview Area

Post by LuNik »

Hi,
I just figured out that this behavior only happens when viewing raw files of my Olympus OMD-EM1II/III and the OMDS OM-1.
Zooming into raw files of my former Olympus OMD EM-5 II and my Nikon D700 work fine! tiff and jpg also work!

Best regards
Ludger
User avatar
xnview
Author of XnView
Posts: 38817
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Error when zooming into a photo in Preview Area

Post by xnview »

which version?
Pierre.
LuNik
Posts: 13
Joined: Thu Aug 04, 2022 8:24 am

Re: Error when zooming into a photo in Preview Area

Post by LuNik »

Bonjour Pierre,

I use XnView MP Windows 1.02 64Bit, Libformat version 7.114

Best regards
Ludger
User avatar
xnview
Author of XnView
Posts: 38817
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Error when zooming into a photo in Preview Area

Post by xnview »

could you send me a screen cast?
Pierre.
User avatar
helmut
Moderator
Posts: 8688
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Error when zooming into a photo in Preview Area

Post by helmut »

LuNik wrote: Mon Sep 05, 2022 11:23 am... Generally it seems that the center point for the magnification is depending on the mouse position ...
Just to make sure: Zooming is always at position of mouse cursor. You won't notice as long as the complete window fits into the screen but when zooming more your image will be zoomed at cursor position. This allows users to have a look at any position in detail easily. Please note that you can move the previewed and zoomed image with right mouse button (keep it pressed and then drag the image).
LuNik
Posts: 13
Joined: Thu Aug 04, 2022 8:24 am

Re: Error when zooming into a photo in Preview Area

Post by LuNik »

Hi Pierre and Helmut,

@Helmut: Viewing for example tif or jpg files or raw files of my Olympus OMD EM-5 II and Nikon D700 it works exactly the way you described it.
I can notice the 'strange behavior' only when viewing orf files of my Olympus OMD-EM1II/III and the OMDS OM-1!!!

@Pierre: Instead of posting some screenshots, wouldn't it be easier for you if I upload a orf file???

Best regards
Ludger
LuNik
Posts: 13
Joined: Thu Aug 04, 2022 8:24 am

Re: Error when zooming into a photo in Preview Area

Post by LuNik »

Hi,
here are some screenshots of the behavior with zooming into an ORF of an OM-1 at 26%, 100%, 142% and 200%. The mouse pointer always points to the top of the tower expect the step from 142 to 200% where it wasn't in the visible area ...

Best regards
Ludger
You do not have the required permissions to view the files attached to this post.
User avatar
helmut
Moderator
Posts: 8688
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Error when zooming into a photo in Preview Area

Post by helmut »

Thank you for your posting screenshots, Ludger. This looks really strange and like a bug.
LuNik wrote: Tue Sep 13, 2022 7:41 am... @Pierre: Instead of posting some screenshots, wouldn't it be easier for you if I upload a orf file???
I've tried myself to reproduce the problem but didn't succeed. I think it would be good and helpful if you uploaded and ORF file which has problems when zooming. My guess is that it has something to do with screen resolution and or Windows' scaling. But let's see whether the bug can be reproduced with the ORF file that you'll provided.
LuNik
Posts: 13
Joined: Thu Aug 04, 2022 8:24 am

Re: Error when zooming into a photo in Preview Area

Post by LuNik »

Hi Helmut,
sry, couldn't upload an ORF file even if zipped ... Error: File too large. The zip is approx. 18MB. Have you got an idea? Or an email so that I can send the file?

As mentioned before I use a 4k monitor at a resolution of 3840 x 2160 with Win 11 ...

Best regards
Ludger
User avatar
helmut
Moderator
Posts: 8688
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Error when zooming into a photo in Preview Area

Post by helmut »

Right, file upload of this forum has it's limitations. You could upload to a file hoster or alternatively send it via e-mail. I've just sent you a PM with mail addresses.

Related topic:
- How to contact the author
LuNik
Posts: 13
Joined: Thu Aug 04, 2022 8:24 am

Re: Error when zooming into a photo in Preview Area

Post by LuNik »

Hi Pierre, hallo Helmut,
I could now find out that the behavior has something to do with the Setting "High Zoom Quality" in the Settings|View dialog when using the embedded jpg for the preview.
If I switch to "Never" everything works fine!!!
Beside the described behavior changing this to other settings sometimes a strange pattern at a zoom level of 51% occurs!!! At all other zoom levels the photo looks ok!!! At 142% it is shifted to the upper left (at some settings of "High Zoom Quality" for example "Zoom-out"/"Bicubic").

As I said before: If I switch to "Never" everything works fine!!!

XnViewMP Options View Pattern.jpg
What exactly does "High Zoom Quality" do??? Changed this setting so often now ... what is the default?

Best regards
Ludger
You do not have the required permissions to view the files attached to this post.
LuNik
Posts: 13
Joined: Thu Aug 04, 2022 8:24 am

Re: Error when zooming into a photo in Preview Area

Post by LuNik »

SORRY .. . When I checked out all those options at "Settings|View" I accidentally changed "Pixel ratio". That caused the strange pattern!!!

So, just to clarify: The behavior of the preview when zooming into a photo in ORF format (OM-D Em1II/III and OM-1) seems to have something to do with the setting of "High Zoom Quality". When setting this to "Never" it works fine otherwise the center point somehow shifts to the upper left.

Sorry for the confusion!!!
Ludger
User avatar
xnview
Author of XnView
Posts: 38817
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Error when zooming into a photo in Preview Area

Post by xnview »

If you change high zoom quality, you have the strange behavior?? 'Camera RAW' has which value?
Pierre.
LuNik
Posts: 13
Joined: Thu Aug 04, 2022 8:24 am

Re: Error when zooming into a photo in Preview Area [Solved]

Post by LuNik »

>>>If you change high zoom quality, you have the strange behavior??<<<
YES!
  • "Never"
    works well
  • "Zoom-out", "Zoom-in" and "Zoom-out& Zoom-in"
    at 142% only a little part of the photo is visible any more, looks like the photo is shifted to the upper left corner. From 200% to 1600%
    it works normal again. In some (rare) cases the effect starts when zooming at 200%. Perhaps depending on the position of the mouse pointer???
It drives me nuts, really hard to reproduce in a reliable way ...

Thanks for your efforts!!!!!!!!!!!!!
Ludger