1.0 MacOS: Window size issues

Bugs which have been reproduced by a second user or the developer, or features to do

Moderators: XnTriq, helmut, xnview, Dreamer

newkind
Posts: 1
Joined: Mon Jul 18, 2022 7:42 am

1.0 MacOS: Window size issues

Post by newkind »

Hi!

First of all thank you for this great piece of software! I just discovered app and I'm not sure how I was able to live without it before :)

So I wanted to report an issue with window sizing. I have set Preferences > View > Auto Image Size -> Fit window to image but I'm noticing 3 issues with window sizing.

#1) When I'm opening an image on my secondary display (I have 3 monitors setup) - the window is always maximized. Even if I resize it to be smaller, quit XnView and reopen the image - the window will be again maximized. This doesn't happen on my main display. If I open the XnView MP on my main display - the window will be adjusted to the image.

Video of what the issue #1 looks like: https://cln.sh/J2VoXQ

#2) If when zooming in the window size will get to the maximum size of the screen and you won't resize it manually (using mouse) before quitting XnView MP, the next time you will open the app/image it will be again maximized, and not adjusted to the image. This is similar to #1 but it happens on my main screen. So I need to remember to always resize the window before quitting the XnView.

Video of what the issue #2 looks like: https://cln.sh/YAw1OJ

#3) The window adjusts nicely with the image (using the zoom button) until the window will get the maximum size of the screen, then it sticks and it doesn't scale down when you zoom out. You need to use mouse to scale the window again.

Video of what the issue #3 looks like: https://cln.sh/WQHVLh

Extra suggestion - allow the background color of the app to be semi-transparent like other apps on MacOS :) This would be a neat feature!

One more time thank you for all your hard work!
User avatar
xnview
Author of XnView
Posts: 38817
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.0 MacOS: Window size issues

Post by xnview »

Thanks to your detailed description I can reproduce
Pierre.