Page 1 of 1

0.93.1 EXIF Rotation Not Updating Timestamp

Posted: Sun Apr 28, 2019 6:18 am
by metal450
XnViewMP v0.93.1 64bits for Windows

With all of the "Keep original date/time" options disabled (shown here: http://take.ms/AKc6Y) and "Change EXIF orientation only" enabled (shown here: http://take.ms/N9dlO)...

...In Browse Mode, the buttons "Rotate Clockwise" and "Rotate Counter Clockwise" (shown here: http://take.ms/tSYtS) do NOT update the timestamp of the file when used (bug #1).

In View Mode, if you customize the toolbar to add those two commands - "Rotate Clockwise" and "Rotate Counter Clockwise" (shown here: http://take.ms/3244Q), it DOES update the timestamp of the file, as expected. However, you'll notice that the buttons are missing their icons (bug #2)

Re: 0.93.1 EXIF Rotation Not Updating Timestamp

Posted: Mon Apr 29, 2019 9:13 am
by xnview
:bugconfirmed: Thanks to your detailed description I can reproduce the problem.

Re: 0.93.1 EXIF Rotation Not Updating Timestamp

Posted: Thu May 02, 2019 5:57 pm
by metal450
Addendum: in the case of the view mode, as mentioned, it is updating the timestamp. However, on closer examination, it's not actually always rotating by just setting the exif flag - sometimes it's still transposing the x,y pixels, contrary to the setting (verified by using BeyondCompare to diff the before/after image files). This doesn't occur for all photos - just some.

So:

1) In Browse, rotate doesn't update the timestamp (despite settings)
2) In View, rotate buttons are missing icons
3) In View, rotate is not doing so via exif flag for some photos (despite settings)

Re: 0.93.1 EXIF Rotation Not Updating Timestamp

Posted: Tue Aug 27, 2019 12:28 pm
by xnview
See issue for current status and some details.

Re: 0.93.1 EXIF Rotation Not Updating Timestamp

Posted: Tue Sep 17, 2019 10:16 am
by xnview
This problem is supposed to be fixed in XnView MP 0.94. Please check and confirm the bug fix here.