0.93.1 EXIF Rotation Not Updating Timestamp

Bugs which have been reproduced by a second user or the developer

Moderator: Dreamer

Post Reply
metal450
Posts: 11
Joined: Sun Apr 28, 2019 6:01 am

0.93.1 EXIF Rotation Not Updating Timestamp

Post by metal450 » Sun Apr 28, 2019 6:18 am

XnViewMP v0.93.1 64bits for Windows

With all of the "Keep original date/time" options disabled (shown here: http://take.ms/AKc6Y) and "Change EXIF orientation only" enabled (shown here: http://take.ms/N9dlO)...

...In Browse Mode, the buttons "Rotate Clockwise" and "Rotate Counter Clockwise" (shown here: http://take.ms/tSYtS) do NOT update the timestamp of the file when used (bug #1).

In View Mode, if you customize the toolbar to add those two commands - "Rotate Clockwise" and "Rotate Counter Clockwise" (shown here: http://take.ms/3244Q), it DOES update the timestamp of the file, as expected. However, you'll notice that the buttons are missing their icons (bug #2)

User avatar
xnview
Author of XnView
Posts: 31364
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.93.1 EXIF Rotation Not Updating Timestamp

Post by xnview » Mon Apr 29, 2019 9:13 am

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.

metal450
Posts: 11
Joined: Sun Apr 28, 2019 6:01 am

Re: 0.93.1 EXIF Rotation Not Updating Timestamp

Post by metal450 » Thu May 02, 2019 5:57 pm

Addendum: in the case of the view mode, as mentioned, it is updating the timestamp. However, on closer examination, it's not actually always rotating by just setting the exif flag - sometimes it's still transposing the x,y pixels, contrary to the setting (verified by using BeyondCompare to diff the before/after image files). This doesn't occur for all photos - just some.

So:

1) In Browse, rotate doesn't update the timestamp (despite settings)
2) In View, rotate buttons are missing icons
3) In View, rotate is not doing so via exif flag for some photos (despite settings)

Post Reply