Compare mode: wrong descriptions for colour labels

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
mudo_j
Posts: 13
Joined: Fri Feb 17, 2017 7:01 pm

Compare mode: wrong descriptions for colour labels

Post by mudo_j » Tue Mar 19, 2019 8:42 pm

In compare mode, in the right-click context menu, the text descriptions for colour labels don't match the icons, they are messed up.

0.91 on Ubuntu Linux, default settings

Image

0.93/64-bit on Windows 10, custom settings

Image

Have a nice evening!

User avatar
xnview
Author of XnView
Posts: 31918
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Compare mode: wrong descriptions for colour labels

Post by xnview » Mon Apr 01, 2019 11:19 am

do you have changed labels in settings>Metadata>Labels??
Pierre.

mudo_j
Posts: 13
Joined: Fri Feb 17, 2017 7:01 pm

Re: Compare mode: wrong descriptions for colour labels

Post by mudo_j » Tue Apr 02, 2019 9:42 pm

For green label, for instance, default settings in English are
Label: Personal
Read: Green, Approved
Write: Green

In browser mode, everything works as expected, green label is described as Personal and Green is written to XMP-xmp:Label, when writing is enabled.

In Compare mode - with two pictures being compared side by side - in the context menu, green label becomes Work, blue is Personal, red is Uncolored, and there is another Uncolored at the bottom - like on my first screenshot.

Custom settings for the second screenshot are simple:
Label: Green
Read: Green
Write: Green,
etc. for all colours.
Obviously, in compare mode, green becomes Yellow etc.

So I can reproduce this with untouched default settings or custom settings.

I hope this makes sense.

mudo_j
Posts: 13
Joined: Fri Feb 17, 2017 7:01 pm

Re: Compare mode: wrong descriptions for colour labels

Post by mudo_j » Thu Apr 11, 2019 7:00 pm

Perhaps I should have started the thread with this screenshot:
Browser vs Compare, default settings
zdruzba3.png
Browser vs Compare colour labels descriptions don't match

User avatar
xnview
Author of XnView
Posts: 31918
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Compare mode: wrong descriptions for colour labels

Post by xnview » Mon Apr 15, 2019 1:27 pm

:bugconfirmed: Thanks to your detailed description I can reproduce
Pierre.

User avatar
xnview
Author of XnView
Posts: 31918
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Compare mode: wrong descriptions for colour labels

Post by xnview » Wed Jul 17, 2019 12:18 pm

See issue for current status and some details. I'll post here once the problem has been fixed.
Pierre.

User avatar
xnview
Author of XnView
Posts: 31918
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Compare mode: wrong descriptions for colour labels

Post by xnview » Tue Sep 17, 2019 10:24 am

This problem is supposed to be fixed in XnView MP 0.94. Please check and confirm the bug fix here.
Pierre.

mudo_j
Posts: 13
Joined: Fri Feb 17, 2017 7:01 pm

Re: Compare mode: wrong descriptions for colour labels

Post by mudo_j » Thu Sep 19, 2019 9:05 am

Fixed, works as expected in 0.94 beta 1.
Have a nice day!

Post Reply