Perte de métadonnées avec Ctrl I

Bugs which have been reproduced by a second user or the developer

Moderator: Dreamer

Post Reply
User avatar
michel038
Posts: 322
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Perte de métadonnées avec Ctrl I

Post by michel038 » Mon Dec 10, 2018 11:17 pm

Version V0.93 Windows 7.

Paramètres de la fenêtre Editer IPTC/XMP :
- Dans le dernier onglet, les trois premières options sont cochées.
- Ne pas charger les champs est coché.
J'attends donc que la deuxième option : "Garder la valeur courante du tag si le champ est vide" empêche l'effacement des métadonnées.

-Sélectionnez deux images ou plus contenant un mot clé, ou une légende ou autre.
-Entrez un titre dans la première image, Ecrire.
-Passez à la deuxième , entrez un titre, Ecrire
Vérifiez les métadonnées :
- Dans la première image, toutes les métadonnées qui étaient présentes avant l'opération ont disparu. Bug.
- Dans la deuxième image, et les suivantes si vous avez fait la manip sur un lot, toutes les métadonnées sont OK.

Hypothèse : Je suppose que le bouton "Ecrire" , lorsqu'il agit sur la première image, se comporte comme si elle était seule à être sélectionnée, c'est à dire qu'il force l'écriture des champs, même vides.

Test réalisé sur 2 à 4 images, avec des métadonnées légende, mots clés ou ville, en IPTC et XMP.

User avatar
xnview
Author of XnView
Posts: 31364
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Perte de métadonnées avec Ctrl I

Post by xnview » Thu Dec 13, 2018 1:02 pm

je ne reproduis pas, les anciennes valeurs des champs sont bien lues?
Pierre.

User avatar
michel038
Posts: 322
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: Perte de métadonnées avec Ctrl I

Post by michel038 » Thu Dec 13, 2018 3:08 pm

C'est l'option "ne pas charger les champs" qui pose problème. (Si on enlève cette option, le bouton "Ecrire" fonctionne bien, image par image.)

Or, je laisse toujours cette option cochée, car en cas d'oubli, c'est la cata, le bouton "écrire tous" devient hyper dangereux .
J'ai supposé que l'option "Garder la valeur courante du tag si le champ est vide" me permettait de conserver en permanence l'option ne pas charger les champs.

Donc, si je reprends le cas décrit, ( de manière plus claire j'espère)
la fenêtre "Éditer iptc xmp" a les options suivantes dans le dernier onglet :
- les trois options sont cochées et l'option "ne pas charger les champs" est cochée aussi.

- Sélectionner deux images contenant une légende, et ouvrir la fenêtre Editer iptc xmp.
- Ajouter un titre dans la première image, cliquer "Ecrire", ajouter un titre dans la deuxième image, cliquer Ecrire, fermer la fenêtre.

- Vérifier les métadonnées :
dans la première image, il y a seulement le titre. Toutes les autres métadonnées ont disparu. C'est ça qui est anormal.
dans la deuxième image, le titre est bon et la légende est restée intacte

Pour répondre à votre question
les anciennes valeurs des champs sont bien lues?

Dès l'ouverture de la fenêtre d'édition, sur la première image , les champs sont vides , conformément à l'option "ne pas charger les champs"
En passant sur la deuxième image, les champs deviennent visibles, et si on retourne à la première image, ils sont maintenant visibles; et le bug ne se produit pas.
Cela explique pourquoi on a les effets que je décris.
Pour y remédier, il faudrait que l'option "Garder la valeur courante du tag si le champ est vide" ait la priorité sur le bouton "Ecrire"

--- fin ---

J'ai bien conscience que l'option "ne pas charger les champs" est liée au bouton "écrire tous" mais il est fastidieux d'enlever et remettre des options dans des cas d'utilisation finalement assez courants.

On a déja le pb avec "apply parent keywords" qui interfère avec le ctrl-clic, les options d'importation et exportation de la fenêtre Options, métadonnées qui sont liées à "afficher, mise à jour du catalogue ..." , et les trois options du dernier onglet de la fenêtre "editer iptc xmp" qui réclament plusieurs minutes de concentration pour être utilisées à bon escient ... Il faudrait tendre vers une situation où les options seraient rassemblées, et aient une fonction et une seule, "en dur" une fois pour toutes.
N'y voyez aucun reproche, je trouve que xnviewmp est un logiciel formidable (et gratuit !) je souhaite juste essayer de trouver des idées pour en améliorer la performance ou le confort d'utilisation ...
Vous aurez remarqué que je m'intéresse avant tout à la fonction de catalogage, qui n'a pratiquement aucun équivalent dans le monde à ce prix.
Pour la partie visualisation, retouche, modification, traitement et conversions d'images, il y a par contre une infinité de solutions alternatives sur le web (souvent assez mauvaises, certes), mais du coup, cela me parait moins essentiel ...
Et donc, encore merci

User avatar
xnview
Author of XnView
Posts: 31364
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Perte de métadonnées avec Ctrl I

Post by xnview » Thu Dec 13, 2018 6:40 pm

oui ce n'est pas vraiment un bug du coup, car si vous ne chargez pas les champs, cela interfère avec la 3eme option
Pierre.

User avatar
michel038
Posts: 322
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: Perte de métadonnées avec Ctrl I

Post by michel038 » Mon Dec 24, 2018 3:40 pm

j'écrivais
il faudrait que l'option "Garder la valeur courante du tag si le champ est vide" ait la priorité sur le bouton "Ecrire"
En attendant, je fais un certain nombre de clics pour enlever l'option "ne pas charger les champs" et le remettre à la fin (10 clics si vous voulez que l'effet se produise correctement)

il faudrait surtout que l'option "Garder la valeur courante du tag si le champ est vide" soit respectée même dans ce cas

Quant à la troisième option, "modifier le tag seulement s'il est vide" justement, elle était cochée, et les tags qui se sont effacés n'étaient pas vides.

"ne pas charger les champs" telle que je comprends la logique, concerne une autre situation , dans laquelle le bouton "Ecrire tous" peut être utilisé sans tout écrabouiller.
Tout ça n'est pas simple à expliquer, je pense qu'il faudra réfléchir mieux avant de modifier cette partie du programme, j'y reviendrai en 2019 ...

User avatar
xnview
Author of XnView
Posts: 31364
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Perte de métadonnées avec Ctrl I

Post by xnview » Thu Dec 27, 2018 4:13 pm

michel038 wrote:
Mon Dec 24, 2018 3:40 pm
j'y reviendrai en 2019 ...
ok :)
Pierre.

User avatar
michel038
Posts: 322
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: Perte de métadonnées avec Ctrl I

Post by michel038 » Fri Mar 15, 2019 1:19 pm

Ca se résume assez clairement :

- Ne pas charger les champs est coché
- Sélectionner plusieurs images et ouvrir la fenêtre d'édition IPTC, et rester sur la première image

BUG : - L'usage du bouton "Ecrire" ne vérifie pas si l'option "garder la valeur courante du tag si le champ est vide" est cochée

Post Reply