0.86 (Mac): Click and drag copies instead of moves

Moderators: XnTriq, helmut, cday, xnview, Dreamer

Post Reply
trevzilla
Posts: 26
Joined: Wed Jun 29, 2016 10:32 pm

0.86 (Mac): Click and drag copies instead of moves

Post by trevzilla » Thu Jun 08, 2017 10:01 pm

XnView: MP 0.86 - 64 bit
OS: Mac 64bit

When clicking and dragging images from the browser window to the file tree, the images are copied to the new location instead of moved there, even though the new location is on the same physical drive.

Effect: Must delete photos from original location, adding an extra step.

To reproduce:
1. Select files from browser window
2. Click and drag selected file to a new directory in the folder tree (on the same physical drive)
3. Drop files in new directory.
Actual behaviour (bug): Files are copied.

Expected behaviour: Files should be moved.

(I reported this same behavior a while ago with the PC version, and it was fixed in version 0.86. But it seems the same bug exists on the Mac version still)

User avatar
xnview
Author of XnView
Posts: 29572
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86 (Mac): Click and drag copies instead of moves

Post by xnview » Wed Apr 18, 2018 8:10 am

See issue for current status and some details.
Pierre.

User avatar
xnview
Author of XnView
Posts: 29572
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86 (Mac): Click and drag copies instead of moves

Post by xnview » Thu Jun 07, 2018 9:44 am

This problem is supposed to be fixed in XnView MP 0.91. Please check and confirm the bug fix here.
Pierre.

Post Reply