Erreurs ou anomalies lors de la génération des vignettes

Questions générales en Français

Moderators: XnTriq, helmut, xnview

Darthxnview
Posts: 24
Joined: Sat Oct 21, 2023 10:18 am

Erreurs ou anomalies lors de la génération des vignettes

Post by Darthxnview »

Salut

J'ai trois problèmes mais ils sont liés: ils se produisent toujours pendant l'affichage/génération des vignettes:

Le premier c'est que quand je sélectionne un répertoire qui contient des grosses images (définition donc lent ou alors beaucoup d'images) et que pendant que Xnview scan le répertoire je double-clique sur une image où la vignette N'EST PAS ENCORE GENEREE (logo Xnview jpeg, etc... ) pour l'afficher en plein écran, il m'ouvre une nouvelle session de Xnview sur le même répertoire. Mais il ne le fait pas si je clique sur une image où la vignette est affichée. Et il m'ouvre un nouveau Xnview autant de fois que je clique pour afficher en plein écran

Le deuxième c'est un peu pareil, ça se passe aussi pendant qu'il génère (ou affiche) les vignettes: J'ouvre deux sessions de Xnview, les deux fenêtres affichées. Si je glisse un répertoire de l'une vers l'autre en COPIE il n'y a pas de problème, mais si je fais un DÉPLACEMENT (glisser + Shift), si il n'a pas terminé les vignettes il m'ouvre un popup "Copy Warning: Cannot remove source", si je lui dit "réessayer" il ouvre la fenêtre "remplacer/ avec", donc en fait il semble avoir déjà copié l'image et veut le remettre et donc trouve un doublon. Si on lui dit de remplacer il peut refaire l'erreur plusieurs fois.
Il se passe la même chose si on utilise le menu clic-droit: "déplacer vers..."

Le dernier c'est si on supprime un répertoire (dans l'arborescence) pendant qu'il affiche les vignettes: il affiche le popup Windows: "Fichier en cours d'utilisation", si je clic "réessayer" alors qu'il n'a pas terminé les vignettes j'ai de nouveau le message.

Voilà, j'espère que vous arriverez à reproduire les anomalies, il faut que les images soient grosses ou qu'il y ait beaucoup d'images pour avoir le temps de faire les manipulations avant la fin de l'affichage.

Xnview MP 1.6.2 64bits
User avatar
xnview
Author of XnView
Posts: 43611
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Erreurs ou anomalies lors de la génération des vignettes

Post by xnview »

Darthxnview wrote: Tue Dec 12, 2023 9:47 pm Le premier c'est que quand je sélectionne un répertoire qui contient des grosses images (définition donc lent ou alors beaucoup d'images) et que pendant que Xnview scan le répertoire je double-clique sur une image où la vignette N'EST PAS ENCORE GENEREE (logo Xnview jpeg, etc... ) pour l'afficher en plein écran, il m'ouvre une nouvelle session de Xnview sur le même répertoire. Mais il ne le fait pas si je clique sur une image où la vignette est affichée. Et il m'ouvre un nouveau Xnview autant de fois que je clique pour afficher en plein écran
Alors effectivement si le fichier n'est pas encore analysé, il ne peut savoir si c'est une image ou non
Le deuxième c'est un peu pareil, ça se passe aussi pendant qu'il génère (ou affiche) les vignettes: J'ouvre deux sessions de Xnview, les deux fenêtres affichées. Si je glisse un répertoire de l'une vers l'autre en COPIE il n'y a pas de problème, mais si je fais un DÉPLACEMENT (glisser + Shift), si il n'a pas terminé les vignettes il m'ouvre un popup "Copy Warning: Cannot remove source", si je lui dit "réessayer" il ouvre la fenêtre "remplacer/ avec", donc en fait il semble avoir déjà copié l'image et veut le remettre et donc trouve un doublon. Si on lui dit de remplacer il peut refaire l'erreur plusieurs fois.
Il se passe la même chose si on utilise le menu clic-droit: "déplacer vers..."
Je vais vérifier....
Le dernier c'est si on supprime un répertoire (dans l'arborescence) pendant qu'il affiche les vignettes: il affiche le popup Windows: "Fichier en cours d'utilisation", si je clic "réessayer" alors qu'il n'a pas terminé les vignettes j'ai de nouveau le message.
Essayez avec la 1.6.3
Pierre.