Page 1 of 4

Ouverture XnView MP très lente

Posted: Wed Dec 12, 2018 8:28 am
by freewee
Bonjour
j' utilise XnView MP depuis longtemps, il y a quelques années, son ouverture était quasi instantanée, mais a partir d' une certaine version (laquelle??? impossible de le dire...), la première ouverture du logicielle ressemble à celle de Ph.....op à une certaine époque, on a le temps de voir venir, plusieurs secondes!
Donc il s' agit de la première ouvertute lors d' une session, les ouvertures suivantes sont rapides. Ceci se produit en ouvrant directement XnView, en ouvrant une image ou en utilisant XnView shell extension.
Lors de la première ouverture de fenêtre, je peux voir brièvement en haut à gauche de la fenêtre: <vide> qui disparait rapidement.
Ceci se produit sous W7 ou W10 64b, mais pas sous Ubuntu 18.04 (pas d' équivalent de XnView shell extension à ma connaissance) .
Y a t' il un cache à nettoyer, quelque chose à faire?
Merci de vos conseils, ce logiciel est vraiment top, j' utilise moins Windows, mais ça m' arrive parfois pour des choses très spécifiques qui ne passent pas dans Ubuntu!
Merci encore!

Re: Ouverture XnView MP très lente

Posted: Wed Dec 12, 2018 6:40 pm
by xnview
XnView MP s'ouvre sur l'explorateur? pas d'onglet image?

Re: Ouverture XnView MP très lente

Posted: Wed Dec 12, 2018 6:56 pm
by freewee
Bonsoir
Je viens de re tester dans W7, ouverture d' un jpeg en cliquant sur l' imagette de shell extension, une dizaine de secondes avant ouverture, c' est l' onglet image qui s' affiche, pas l' explorateur; les réouvertures sont quasi instantanées.

Re: Ouverture XnView MP très lente

Posted: Thu Dec 13, 2018 1:03 pm
by xnview
sans passer par le shell extension, si vous faites un deplcaer&poser sur l'icone XnViewMP d'une image, pareil?
Et seule la 1ere ouverture prends du temps (apres reboot)?

Re: Ouverture XnView MP très lente

Posted: Thu Dec 13, 2018 2:45 pm
by freewee
Bonjour
Quel que soit le moyen d' ouverture , clic direct sur fichier, glisser deposer, la première ouverture de XnView MP est très lente, parfois 15 secondes! puis le soft s' ouvre avec <vide> marqué brièvement en haut à gauche du menu du haut , puis apparait l' onglet image.
La réouverture dans une même session est par contre très rapide, le problème ne survient qu' une fois après redémarrage du PC.
Merci

Re: Ouverture XnView MP très lente

Posted: Thu Dec 13, 2018 6:38 pm
by xnview
freewee wrote:
Thu Dec 13, 2018 2:45 pm
Quel que soit le moyen d' ouverture , clic direct sur fichier, glisser deposer, la première ouverture de XnView MP est très lente, parfois 15 secondes! puis le soft s' ouvre avec <vide> marqué brièvement en haut à gauche du menu du haut , puis apparait l' onglet image.
La réouverture dans une même session est par contre très rapide, le problème ne survient qu' une fois après redémarrage du PC.
15 sec, cela fait beaucoup! Avez vous essayez de renommer le xnview.ini & XnView.db?

Re: Ouverture XnView MP très lente

Posted: Thu Dec 13, 2018 8:40 pm
by freewee
Bonsoir
Je viens de faire quelques tests, il n' y a pas de différence avec les .ini et .db natifs ou modifiés.
Pour info je viens de chronométrer, dans le meilleurs des cas , pour Windows sur SSD c' est 7 secondes, les 15 secondes que j' avais obtenues étaient avec Windows 10 sur un disque normal...
Bon ce n' est pas énorme, mais beaucoup plus que sous Ubuntu ou la première ouverture est quasi instantanée... Et ce n' était pas le comportement de XnView il y a quelques années!(pour moi) je l' utilisais pour une vision rapide de mes images; je me souviens finalement avoir fait l'essai de renommer les .ini et .db il y a plusieurs années, car j' ai retrouvé ces fichiers ".back", que j' avais modifié donc pour tests; je n' avais pas insisté à l' époque car je migrais vers Ubuntu!

Re: Ouverture XnView MP très lente

Posted: Fri Dec 14, 2018 9:22 am
by xnview
Meme 7 secondes, ce n'est pas normal. J'ai au grand max 2 secondes d'ouverture la 1ere fois.
Vous souvenez vous de la version qui s'ouvrait plus rapidement?

Re: Ouverture XnView MP très lente

Posted: Fri Dec 14, 2018 10:43 am
by freewee
Bonjour
Malheureusement, cela se compte en années, puisque c' est survenu au moment ou je commençait à m' intéresser à Ubuntu.
Je viens tester la version 0.72 x64 de 2014 qui fonctionne bien, elle propose l' installation de la dernière version bien sûr, ce qui doit la ralentir un peu, mais ça va quand même vite...
Je vais essayer de tester avec une version ultérieure!

Re: Ouverture XnView MP très lente

Posted: Fri Dec 14, 2018 11:29 am
by xnview
freewee wrote:
Fri Dec 14, 2018 10:43 am
Je viens tester la version 0.72 x64 de 2014 qui fonctionne bien, elle propose l' installation de la dernière version bien sûr, ce qui doit la ralentir un peu, mais ça va quand même vite...
Je vais essayer de tester avec une version ultérieure!
Si vous pouviez me dire à partir de quelle version le delai devient vraiment enorme?
vous etes obligé de redemarrer la machine à chaque test?

Re: Ouverture XnView MP très lente

Posted: Fri Dec 14, 2018 11:36 am
by freewee
Je viens de tester la Version 0.85 64bits (Apr 4 2017), et là le délai de 1er démarrage est long.
Oui je redémarre à chaque fois, avec un SSD c' est assez rapide, il faut quand même attendre un peu que le système se stabilise, j' attend que les processeurs ne travaillent plus pour ne pas interférer avec le test!

Re: Ouverture XnView MP très lente

Posted: Fri Dec 14, 2018 11:44 am
by xnview
freewee wrote:
Fri Dec 14, 2018 11:36 am
Je viens de tester la Version 0.85 64bits (Apr 4 2017), et là le délai de 1er démarrage est long.
Oui je redémarre à chaque fois, avec un SSD c' est assez rapide, il faut quand même attendre un peu que le système se stabilise, j' attend que les processeurs ne travaillent plus pour ne pas interférer avec le test!
est-ce entre la 0.79 et 0.80?

Re: Ouverture XnView MP très lente

Posted: Fri Dec 14, 2018 11:50 am
by freewee
Je vais chercher ces versions!

Re: Ouverture XnView MP très lente

Posted: Fri Dec 14, 2018 1:24 pm
by freewee
Bon après quelques erreurs dans les téléchargement en 32 ou 64b! qui m' ont obligé à refaire les tests, en 64b, l' augmentation du délai de démarrage semble intervenue entre la version 0.72 et 0.79, je suis revenu en arrière car je ne voyais pas de différence entre la 0.79 et la 0.80...
Reste a tester les 0.7x...

Re: Ouverture XnView MP très lente

Posted: Fri Dec 14, 2018 2:43 pm
by xnview
0.75 lente aussi?