Tags not sticking between folders

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, helmut, xnview

ShrapNull
Posts: 17
Joined: Sat Jan 28, 2012 4:31 pm

Tags not sticking between folders

Post by ShrapNull »

If I tag photos, when I change folders and come back the tags are nowhere to be seen. They have definitely worked previously.

And yes, I have "clear the list of tagged files" set to never in the settings.

I am on linux, using the latest .deb package.

Has anyone else found this issue or any workarounds or fixes for it?
Thanks in advance

------
On an unrelated note, is there a portable linux version?
User avatar
xnview
Author of XnView
Posts: 39378
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Tags not sticking between folders

Post by xnview »

Catalog is enabled?
Pierre.
ShrapNull
Posts: 17
Joined: Sat Jan 28, 2012 4:31 pm

Re: Tags not sticking between folders

Post by ShrapNull »

Yes, the catalog is enabled.

However, about a week ago I turned the catalog off. Then later that same day I turned it back on again.
Now tagging won't remember between folders. Is it possible there is a bug after a re-enable?

Thank you for replying :)
ShrapNull
Posts: 17
Joined: Sat Jan 28, 2012 4:31 pm

Re: Tags not sticking between folders

Post by ShrapNull »

In fact, now I've investigated further, any stars or colours I add don't stick between folders either.
User avatar
xnview
Author of XnView
Posts: 39378
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Tags not sticking between folders

Post by xnview »

where do you save the catalog?
Pierre.
ShrapNull
Posts: 17
Joined: Sat Jan 28, 2012 4:31 pm

Re: Tags not sticking between folders

Post by ShrapNull »

xnview wrote: Tue Jan 10, 2023 1:54 pm where do you save the catalog?
I store it in the user system file:
/home/my-user-name/.config
ShrapNull
Posts: 17
Joined: Sat Jan 28, 2012 4:31 pm

Re: Tags not sticking between folders

Post by ShrapNull »

For further info, the files in that location are:

bookmark.ini
default.bar
default.keys
Thumb.db
xnview.ini
XnView.db

I assume the catalog is XnView.db?

Many thanks in advance
cday
XnThusiast
Posts: 3577
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Tags not sticking between folders

Post by cday »

ShrapNull wrote: Tue Jan 10, 2023 4:08 pm
xnview wrote: Tue Jan 10, 2023 1:54 pm where do you save the catalog?
I store it in the user system file:
/home/my-user-name/.config

May I ask whether your .config folder Properties > Permissions -- File access includes 'Read and write' permission?

I am using Linux Mint, with limited knowledge of Linux, but your issue seems to be possibly related to write permissions... :?:
ShrapNull
Posts: 17
Joined: Sat Jan 28, 2012 4:31 pm

Re: Tags not sticking between folders

Post by ShrapNull »


May I ask whether your .config folder Properties > Permissions -- File access includes 'Read and write' permission?

I am using Linux Mint, with limited knowledge of Linux, but your issue seems to be possibly related to write permissions... :?:
I'm a fairly new user to linux, I just moved to it this year. Is this what you requested?
ls -l $HOME/.config/xnviewmp

-rw-rw-r-- 1 myusername myusername 70 Nov 9 10:56 bookmark.ini
-rw-r--r-- 1 root root 744 Dec 23 13:53 default.bar
-rw-r--r-- 1 root root 5722 Dec 23 13:53 default.keys
-rw-r--r-- 1 myusername myusername 4152676352 Jan 11 11:40 Thumb.db
-rw-r--r-- 1 root root 44896256 Jan 11 11:40 XnView.db
-rwxrwxrwx 1 root root 26851 Jan 11 11:16 xnview.ini
cday
XnThusiast
Posts: 3577
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Tags not sticking between folders

Post by cday »

I moved to Linux five years ago specifically to avoid Windows 10, and have only strictly necessary knowledge myself... :wink:

In the Mint GUI, right-clicking on the .config folder, I see this:

Screenshot_1.png

When I click on the top Owner -- File access dropdown, there is an option to activate Read and write access. That is what I am suggesting, very speculatively, might be relevant to the fact that your tags are not sticking.

Note: Screenshot of opened menu not possible on Linux for some reason.
You do not have the required permissions to view the files attached to this post.
ShrapNull
Posts: 17
Joined: Sat Jan 28, 2012 4:31 pm

Re: Tags not sticking between folders

Post by ShrapNull »

This is a screenshot of the same folder. AFAICS it looks correct. The smudged name is my username.
xnviewFolderSettings.png

I've tried uninstalling & reinstalling, but it didn't fix it. Possibly a bug, but I can't ask anyone to disable & re-enable the catalog because it could delete all their saved stuff.

Perhaps the db file is corrupt. I might try to delete it to see what happens

Thank you for the help btw
You do not have the required permissions to view the files attached to this post.
cday
XnThusiast
Posts: 3577
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Tags not sticking between folders

Post by cday »

In your screenshot above, File access is shown as '--' which I interpret as 'no access' rather than the suggested option of Read and write.
ShrapNull wrote: Wed Jan 11, 2023 12:29 pm I can't ask anyone to disable & re-enable the catalog because it could delete all their saved stuff.
You are right to proceed with caution, but on my understanding enabling read and write permissions should do no more than enable updated values to be written so that tags stick... :?:

If you are uncomfortable maybe you could devise a test that could be performed after backing up any relevant databases, their location can be found in Tools > Settings > Integration.

Maybe Pierre has more ideas.
ShrapNull
Posts: 17
Joined: Sat Jan 28, 2012 4:31 pm

Re: Tags not sticking between folders

Post by ShrapNull »

I renamed XnView.db to something else. Then started xnview again & it automatically recreated an XnView.db file.

However, the issue remains.

I think this looks like it is definitely a bug.

@Pierre, can you recreate this by disabling the catalog & then re-enabling it again on a linux system?
User avatar
xnview
Author of XnView
Posts: 39378
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Tags not sticking between folders

Post by xnview »

ShrapNull wrote: Wed Jan 11, 2023 1:55 pm @Pierre, can you recreate this by disabling the catalog & then re-enabling it again on a linux system?
In the same instance? If you restart same problem?
Pierre.
KLE-France
Posts: 33
Joined: Mon Jan 14, 2019 3:00 pm

Re: Tags not sticking between folders

Post by KLE-France »

Hi all,

I'm on Windows, so, the chance of this being relevant is slim, but I had previously reported a very similar issue where images processed with Affinity Photo will sometimes show the behavior you're speaking of, that is, a keyword (tag) written into an image will (sometimes) disappear when I change folders, change programs, close XnView MP, etc.

The issue is still there for me to this day... The "randomness" of the issue in my case is a real frustration for Pierre, I think.

In any case, I saw your post and thought I'd put this out there.

Good luck.