Video error

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, helmut, xnview

Joseph1984
Posts: 9
Joined: Sun Dec 11, 2022 6:11 pm

Video error

Post by Joseph1984 »

Hi, thanks for this great software, but I have a weird error on the display of any kind of video inside the program, the videos like MP4, avi, webm, etc, are mirrored like the images I add to this message. Is there any way to fix this? Thank you.
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 39378
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Video error

Post by xnview »

strange on windows 10?
Pierre.
Joseph1984
Posts: 9
Joined: Sun Dec 11, 2022 6:11 pm

Re: Video error

Post by Joseph1984 »

Yes, I try installing an old version of the Xnview MP but is the same, since 103.1 I have the problem on all the video files
User avatar
xnview
Author of XnView
Posts: 39378
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Video error

Post by xnview »

could you send me a sample file?
Pierre.
Joseph1984
Posts: 9
Joined: Sun Dec 11, 2022 6:11 pm

Re: Video error

Post by Joseph1984 »

The error on MP and the sample file https://i.imgur.com/sSQr5fu.mp4
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 39378
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Video error

Post by xnview »

could you change in you xnview.ini,

Code: Select all

debug=2
and send me by PM the content of the debug window
Pierre.
Joseph1984
Posts: 9
Joined: Sun Dec 11, 2022 6:11 pm

Re: Video error

Post by Joseph1984 »

there is no fix for this error? Any help with the videos?
User avatar
xnview
Author of XnView
Posts: 39378
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Video error

Post by xnview »

could you try to delete libEGL & libGLESv2 from XnView's folder?
Pierre.
Joseph1984
Posts: 9
Joined: Sun Dec 11, 2022 6:11 pm

Re: Video error

Post by Joseph1984 »

No luck, the program freeze and must close it to get again response from it
Joseph1984
Posts: 9
Joined: Sun Dec 11, 2022 6:11 pm

Re: Video error

Post by Joseph1984 »

Again sking there is no solve for the problem I have with the videos?
User avatar
xnview
Author of XnView
Posts: 39378
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Video error

Post by xnview »

Joseph1984 wrote: Fri Jan 06, 2023 5:30 pm Again sking there is no solve for the problem I have with the videos?
The author of video component doesn't understand what's happened, you are 2 users with same problem on same card.
you can try to disable the internal video component
Pierre.
Joseph1984
Posts: 9
Joined: Sun Dec 11, 2022 6:11 pm

Re: Video error

Post by Joseph1984 »

xnview wrote: Sat Jan 07, 2023 8:55 am
Joseph1984 wrote: Fri Jan 06, 2023 5:30 pm Again sking there is no solve for the problem I have with the videos?
The author of video component doesn't understand what's happened, you are 2 users with same problem on same card.
you can try to disable the internal video component

Thank you, is there any option on the program to use external codecs or an external video component?
User avatar
xnview
Author of XnView
Posts: 39378
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Video error

Post by xnview »

try editing the xnview.ini

Code: Select all

useInternalVideoPlayer=false
Pierre.
Joseph1984
Posts: 9
Joined: Sun Dec 11, 2022 6:11 pm

Re: Video error

Post by Joseph1984 »

xnview wrote: Tue Jan 10, 2023 1:54 pm try editing the xnview.ini

Code: Select all

useInternalVideoPlayer=false
Thank you, this partially solves the problem, videos of all kinds can now be seen normally, the only detail is that they are not displayed in a loop, even by checking in the option in the settings section. Any fix for that?
User avatar
xnview
Author of XnView
Posts: 39378
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Video error

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.