Videos do not appear in Slideshow

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, helmut, xnview

Appletreed
Posts: 2
Joined: Thu Dec 08, 2022 7:49 pm

Videos do not appear in Slideshow

Post by Appletreed »

Running XnViewMP Version 1.3.1 64bits on Windows 10, and the Slideshow feature seems unable to show video files. A search of the forums here shows posts by other users that suggests that videos work in their slideshows, so I assume it's a feature that should be working.

I've tried various Slideshow settings to see if I could troubleshoot it, but it will either show all black or simply skips to the next non-video file. No audio is played and I've tested it with mp4, webm, and one mov file. Animated gifs work fine.

I did notice that the Show Information feature for the Slideshow fails to show any information onscreen when it displays the video as all black, so maybe it's not loading any of the file.

Videos play normally in the Preview pane.

Have I missed something in the Options panel maybe? Or should I report this as a bug?

Edit: dug up my old copy of XNView (classic) 2.39 and videos work in its Slideshow. Puzzling!
User avatar
xnview
Author of XnView
Posts: 39322
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Videos do not appear in Slideshow

Post by xnview »

Slideshow doesn't yet support video in slideshow
Pierre.
Appletreed
Posts: 2
Joined: Thu Dec 08, 2022 7:49 pm

Re: Videos do not appear in Slideshow

Post by Appletreed »

Ah, so it's a "̶W̶h̶a̶t̶'̶s̶ ̶d̶i̶f̶f̶e̶r̶e̶n̶t̶ ̶i̶n̶ ̶X̶n̶V̶i̶e̶w̶ ̶M̶P̶"̶ "Missing features (compared to XnView Classic)" item. I had checked there but didn't spot it.
Good to know it's expected behavior, thanks for the reply!

edit: fixed features thread title
thoath
Posts: 1
Joined: Mon Jan 09, 2023 9:35 am

Re: Videos do not appear in Slideshow

Post by thoath »

Ts there already a time-schedule when videos will also be displayed in the slideshow?
And it is planned that all available formats will be displayed