Wrong label fonts - help anyone?

Ask for help and post your question on how to use XnView MP.

Moderators: helmut, XnTriq, xnview

bc_is_too_short
Posts: 2
Joined: Mon Sep 19, 2022 11:30 am

Wrong label fonts - help anyone?

Post by bc_is_too_short »

I have a fresh install of XnViewMP 64-bit, Win 10 21H2 (19044.1889).

- some numbers are displayed in non-expected (and not really readable) font:
XN1_Screenshot 2022-09-19 135814.png

- the same happens with some boxes in Settings:
XN2_Screenshot 2022-09-19 140053.png

- no other application does this (this applies to XnView Classic, displaying everything just right)

- I have tried changing fonts via Settings, via theme css file, reinstalling, running non-installed version extracted from zip file, turning off font-manager, everything I could come up with short of reinstalling Windows...

...which leads to a question: what font should display that data? Maybe I have uninstalled some fonts that are necessary for XnView MP?

My regional settings (just in case):
XN3_Screenshot 2022-09-19 141152.png

Thanks!
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 38282
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Wrong label fonts - help anyone?

Post by xnview »

Settings>General - Language is on English?
Pierre.
bc_is_too_short
Posts: 2
Joined: Mon Sep 19, 2022 11:30 am

Re: Wrong label fonts - help anyone?

Post by bc_is_too_short »

English (en) to be precise, although no matter what is set there, the problem persists
User avatar
xnview
Author of XnView
Posts: 38282
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Wrong label fonts - help anyone?

Post by xnview »

with old version you had no problem?
Pierre.
User avatar
michel038
Posts: 942
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: Wrong label fonts - help anyone?

Post by michel038 »

Did you try another font ? Maybe MS Shell Dlg2 (shown in your screenshot) is damaged ?