Resize not working as expected.

Ask for help and post your question on how to use XnView MP.

Moderators: helmut, XnTriq, xnview

chuck902
Posts: 6
Joined: Mon Feb 15, 2010 2:49 pm

Resize not working as expected.

Post by chuck902 »

I want to resize a batch of images and I can't figure out how to get the results I need.

All the images need to be 4.45" wide by 2.5" high. I understand that some of the image has to be cropped off and that is OK. Resolution is not important.

My test input image is 6000x4000 pixels.
From what I understand, Fill should give me what I expect, but it doesn't.

Here are my settings.
XN View post.jpg
Here are the results using various settings.
Fill mode: 4.451" x 2.959" @ 350 ppi
Fit mode: 3.751" x 2.5" @ 350 ppi

I get the correct size if I uncheck Keep Ratio but then the image is distorted.

I've tried combining resize with a few other actions but can't come up with a combination that works.

XnView constantly surprises me with what it can do. Is there a way to do what I need it to do this time?

Thanks!
You do not have the required permissions to view the files attached to this post.
cday
XnThusiast
Posts: 3350
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Resize not working as expected.

Post by cday »

chuck902 wrote: Wed Sep 14, 2022 10:24 pm I want to resize a batch of images and I can't figure out how to get the results I need.

I understand that some of the image has to be cropped off and that is OK.
I think you probably need Canvas resize rather than the Resize action.

Disclosure: I'm not familiar with the Resize action the way you are using it, so possibly that can be used.