Rating not saved when file is moved between folders

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

winterNebs
Posts: 24
Joined: Mon Mar 16, 2020 5:58 am

Rating not saved when file is moved between folders

Post by winterNebs »

Hi, I have the catalog enabled and "export rating in xmp metadata".

When I drag a file (within XnView MP) to another folder it does not save the rating.

I can reproduce this by doing the following:

1. rate a file (ie "4")
2. Drag the file out of the current folder into the parent folder
The file no longer has the rating

Dragging the file back into the original folder shows the rating again

It seems like the path to the file is not updated.

Also turning off export rating does fix it either.

Any help would be appreciated!
winterNebs
Posts: 24
Joined: Mon Mar 16, 2020 5:58 am

Re: Rating not saved when file is moved between folders

Post by winterNebs »

Update:

It seems like rating is saved when moving between folders ONLY when the image shows the "ICC" and "IPTC" icons on the image (since I have some files already tagged externally)

For some reason updating the ratings in XnView will not create ICC or IPTC on the image though.
winterNebs
Posts: 24
Joined: Mon Mar 16, 2020 5:58 am

Re: Rating not saved when file is moved between folders

Post by winterNebs »

Second Update:

Editing the "IPTC-IIM" > Option > Mode

and changing "XMP only" to "IPTC-IIM update XMP"

seems to fix that.

Is there a way for XnViewMP to auto update this for me?
winterNebs
Posts: 24
Joined: Mon Mar 16, 2020 5:58 am

Re: Rating not saved when file is moved between folders

Post by winterNebs »

Update 3:

Seems like everything works after disabling catalog, I will do some more testing

edit:

Seems like that works but there's another issue where the displayed rating is not the same as the metadata.
For example:
- Set img.jpg rating to 5 [The properties says "5 star"]

- Move img.jpg to another folder [The properties says "5 star" but no rating is displayed]

- Set rating of img.jpg in the new folder to 2 [The property now says "2 star"]

- Move back to original folder [The property says "2 star" but 5 stars are displayed]
User avatar
xnview
Author of XnView
Posts: 36389
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Rating not saved when file is moved between folders

Post by xnview »

could you post a screenshot of Settings>Metadata?
It seems that you store rating only in catalog not file, right?
Pierre.
winterNebs
Posts: 24
Joined: Mon Mar 16, 2020 5:58 am

Re: Rating not saved when file is moved between folders

Post by winterNebs »

https://i.imgur.com/p7QjWfh.png

I originally had catalog enabled, now it I disabled it and it seems to work correctly after restarting my computer...

Very strange behavior unfortunately
User avatar
xnview
Author of XnView
Posts: 36389
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Rating not saved when file is moved between folders

Post by xnview »

winterNebs wrote: Mon Oct 18, 2021 9:34 am https://i.imgur.com/p7QjWfh.png

I originally had catalog enabled, now it I disabled it and it seems to work correctly after restarting my computer...

Very strange behavior unfortunately
Not normal, with your settings rating is written in the file. Do you use jpeg file?
The rating of your files comes from XnView or another app?
Pierre.
winterNebs
Posts: 24
Joined: Mon Mar 16, 2020 5:58 am

Re: Rating not saved when file is moved between folders

Post by winterNebs »

xnview wrote: Tue Oct 19, 2021 9:05 am
winterNebs wrote: Mon Oct 18, 2021 9:34 am https://i.imgur.com/p7QjWfh.png

I originally had catalog enabled, now it I disabled it and it seems to work correctly after restarting my computer...

Very strange behavior unfortunately
Not normal, with your settings rating is written in the file. Do you use jpeg file?
The rating of your files comes from XnView or another app?
Rating comes from XnViewMP only. Currently it seems to be working with catalog disabled. Should I test it with catalog enabled again?
User avatar
xnview
Author of XnView
Posts: 36389
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Rating not saved when file is moved between folders

Post by xnview »

winterNebs wrote: Wed Oct 20, 2021 2:06 pm Rating comes from XnViewMP only. Currently it seems to be working with catalog disabled. Should I test it with catalog enabled again?
yes please
Pierre.
winterNebs
Posts: 24
Joined: Mon Mar 16, 2020 5:58 am

Re: Rating not saved when file is moved between folders

Post by winterNebs »

xnview wrote: Thu Oct 21, 2021 5:50 am
winterNebs wrote: Wed Oct 20, 2021 2:06 pm Rating comes from XnViewMP only. Currently it seems to be working with catalog disabled. Should I test it with catalog enabled again?
yes please
It seems like disabling catalog deletes your original catalog, is this normal?

after testing it seems to work, maybe the catalog was corrupted somehow.

As long as the rating is still saved to the images that works for me.
User avatar
xnview
Author of XnView
Posts: 36389
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Rating not saved when file is moved between folders

Post by xnview »

winterNebs wrote: Thu Oct 21, 2021 8:10 pm It seems like disabling catalog deletes your original catalog, is this normal?
No, catalog is cleand only when asked
after testing it seems to work, maybe the catalog was corrupted somehow.

As long as the rating is still saved to the images that works for me.
strange.... Tell me if you have again problems...
Pierre.