Cannot install XnViewMP on fedora

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Ghost_Rider
Posts: 8
Joined: Sun Aug 29, 2021 9:27 pm

Cannot install XnViewMP on fedora

Post by Ghost_Rider »

I just downloaded and tried to install the XnViewMP-linux.x86_64.rpm file and failed with the following.

Code: Select all

# dnf install /home/myuser/Downloads/appimage/xnview/XnViewMP-linux.x86_64.rpm 
Last metadata expiration check: 2:32:21 ago on Sun 29 Aug 2021 04:52:51 PM CDT.
Error: 
 Problem: conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.98.4-2.x86_64
  - nothing provides libQt5Gui.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.98.4-2.x86_64
  - nothing provides libQt5Multimedia.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.98.4-2.x86_64
  - nothing provides libQt5MultimediaGstTools.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.98.4-2.x86_64
  - nothing provides libQt5Network.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.98.4-2.x86_64
  - nothing provides libQt5PrintSupport.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.98.4-2.x86_64
  - nothing provides libQt5WaylandClient.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.98.4-2.x86_64
  - nothing provides libQt5Widgets.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.98.4-2.x86_64
  - nothing provides libQt5XcbQpa.so.5(Qt_5_PRIVATE_API)(64bit) needed by xnview-0.98.4-2.x86_64
(try to add '--skip-broken' to skip uninstallable packages)
I then looked in /usr/lib64/ and found that each and every one of the needed files is actually there. They are also available via the /lib64/ path.
I do not understand why this error occurs since the files are actually installed and available. Does the rpm file have dependencies that are not valid?

My machine is running Fedora 34.
The packages
qt5-qtmultimedia
qt5-qtbase
qt5-qtbase-gui
qt5-qtwayland
provide all the required files and all are installed with version 5.15.2.

I am guessing this is because of the (Qt_5_PRIVATE_API) part of the dependency specified.
I ran "rpm -qpR XnViewMP-linux.x86_64.rpm" and all those files have multiple dependencies listed. The only ones that erred are the ones that specified the (Qt_5_PRIVATE_API).

I did a rpmrebuild on the file and removed the lines with the Qt_5_PRIVATE_API and the lines near the end that attempted to alter the /usr and /usr/bin paths then the resulting rpm file was able to install. However, there is still an error with this when trying to start the app.

Code: Select all

$ xnview
/opt/XnView/XnView: symbol lookup error: /lib64/libk5crypto.so.3: undefined symbol: EVP_KDF_ctrl, version OPENSSL_1_1_1b
$ ls /lib64/libk5crypto.so*
/lib64/libk5crypto.so  /lib64/libk5crypto.so.3  /lib64/libk5crypto.so.3.1
$ dnf list installed openssl
Installed Packages
openssl.x86_64                                                1:1.1.1k-1.fc34                                                @fedora
I have openssl version 1.1.1k installed and the error is related to version 1.1.1b.