Open with associated program does not work (mime type issue?)

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

vommie
Posts: 109
Joined: Sat Apr 14, 2007 2:36 am
Location: Berlin

Open with associated program does not work (mime type issue?)

Post by vommie »

Hello,

when I try to open a file with the associated program, the following dialog appears:

Screenshot_20210823_071046.png

Code: Select all

Error - KIO Client
In the terminal, XnView outputs the following log line:

Code: Select all

## onItemPressed
kf.service.services: KApplicationTrader: mimeType "x-scheme-handler/file" not found
Exaclty the same log entry appears when I triy to open the file with the context menu entry "Open in file explorer", with the same error dialog (but for the path).

It seems the mime type is wrong as it is just 'file'? If I open the file (or others) with the default file manager (Dolphin) or with xdg-open in the terminal there's no problem.

Edit: I've tried around some more.
With the 64bit tar.gz of XnView (xnview.sh) this problem occurs.
With this AUR the problem occurs too.
With this AUR the problem occurs not (but I have a lot of crashes when thumbnails for videos get created, so it's no option).
The AppImage does not even start. /tmp/.mount_XnViewkPXVHQ/usr/XnView/XnView: symbol lookup error: /usr/lib/libkrb5.so.3: undefined symbol: k5_buf_free, version krb5support_0_MIT

System Info:
XnView MP Linux
Version 0.98.4 64bits (May 31 2021)
Libformat version 7.8
Operating System: Manjaro Linux
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Kernel Version: 5.13.5-1-MANJARO (64-bit)
Graphics Platform: X11

Thanks for any support
You do not have the required permissions to view the files attached to this post.
Last edited by vommie on Mon Aug 23, 2021 8:11 am, edited 1 time in total.
User avatar
xnview
Author of XnView
Posts: 36805
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Open with associated program does not work (mime type issue?)

Post by xnview »

i've tried on ubuntu, and no problem
Pierre.