Problem to run MP v.0.93.1

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
Heitor
Posts: 5
Joined: Thu Aug 22, 2013 11:44 pm

Problem to run MP v.0.93.1

Post by Heitor » Mon Oct 07, 2019 8:39 am

./XnView: /usr/lib64/libQt5Core.so.5: version `Qt_5.13' not found (required by /usr/lib64/libQtAVWidgets.so.1)
./XnView: /usr/lib64/libQt5Core.so.5: version `Qt_5.13' not found (required by /usr/lib64/libQt5WebKitWidgets.so.5)
./XnView: /usr/lib64/libQt5Core.so.5: version `Qt_5.13' not found (required by /usr/lib64/libQtAV.so.1)
./XnView: /usr/lib64/libQt5Core.so.5: version `Qt_5.13' not found (required by /usr/lib64/libQt5WebKit.so.5)

Installed Dependency Versions:
qt5-5.9.6-x86_64
qtav-1.13.0
qt5-webkit-5.212.0_alpha3-x86_64
OpenAL-1.19.1-x86_64
woff2-a0d0ed7_20190630-x86_64
hyphen-2.8.8-x86_64
brotli-1.0.7-x86_64

There seems to be a problem with the versions, because I needed to install qt5-5.9.6-x86_64 That is already very old! Because the program does not accept the new versions.

But now I don't know what he complains about, I would like if anyone could let me know which versions of the dependencies are compatible. Because I figured the program being a new version would use the new dependencies too. And so I can't make it work!

I used older versions of what I reported above to solve the problem
qt5-webkit-5.9.1-x86_64
qtav-1.12.0-x86_64

But now he complains ffmpeg-4.2.1-x86_64
But I can't downgrade it. Why do I use it in other programs

See errors below
./XnView: /usr/lib64/libavresample.so.3: version `LIBAVRESAMPLE_3' not found (required by /usr/lib64/libQtAV.so.1)
./XnView: /usr/lib64/libswresample.so.2: version `LIBSWRESAMPLE_2' not found (required by /usr/lib64/libQtAV.so.1)
./XnView: /usr/lib64/libavfilter.so.6: version `LIBAVFILTER_6' not found (required by /usr/lib64/libQtAV.so.1)
./XnView: /usr/lib64/libavcodec.so.57: version `LIBAVCODEC_57' not found (required by /usr/lib64/libQtAV.so.1)
./XnView: /usr/lib64/libavdevice.so.57: version `LIBAVDEVICE_57' not found (required by /usr/lib64/libQtAV.so.1)
./XnView: /usr/lib64/libswscale.so.4: version `LIBSWSCALE_4' not found (required by /usr/lib64/libQtAV.so.1)
./XnView: /usr/lib64/libavformat.so.57: version `LIBAVFORMAT_57' not found (required by /usr/lib64/libQtAV.so.1)
./XnView: /usr/lib64/libavutil.so.55: version `LIBAVUTIL_55' not found (required by /usr/lib64/libQtAV.so.1)

Can anyone help me fix this so that I can run XnView? Without ruining my current system?
I am running XnView binary from its own folder, I noticed that it has these dependencies in its folder, would there be a way for it to use dependencies from its own folder instead of system dependencies?

Heitor
Posts: 5
Joined: Thu Aug 22, 2013 11:44 pm

Solution Found!

Post by Heitor » Mon Oct 07, 2019 9:24 am

Solution Found! Finally!

My inattention, In the program folder there is the file xnview.sh
That does all the magic! Allowing XnView to run portable, without having to install, and without having to install any dependencies.
I just needed to put in the folder lib the following dependency that didn't have libopenal.so.1.19.1 I created a link libopenal.so.1

I run the file xnview.sh and everything worked!
I left the solution here for others who wish to do so.

OBS I can't mark the topic as resolved

claudec
Posts: 2
Joined: Wed Sep 12, 2018 3:23 pm

Re: Problem to run MP v.0.93.1

Post by claudec » Tue Nov 12, 2019 11:13 pm

This issue is very similar to this one.

In some case link creation is not an option, typicaly when

Code: Select all

locate 'libopenal.so'
give no result, then you can install lib using:

Code: Select all

sudo apt install libopenal1

Post Reply