Page 1 of 1

does xnViewMP have an error log?

Posted: Thu Mar 21, 2019 5:14 pm
by limar500
every now and then, xnViewMP freezes, because unresponsive and the only way to close it is to to close it'a process under "Task Manager".
I would like to know what causes it to crash, is there some kind of error log I can take a look at in order to find out?

Re: does xnViewMP have an error log?

Posted: Fri Mar 22, 2019 10:54 am
by xnview
on every folder? at startup?

Re: does xnViewMP have an error log?

Posted: Sat Mar 23, 2019 9:50 am
by limar500
xnview wrote:
Fri Mar 22, 2019 10:54 am
on every folder? at startup?
at some folders, I can't remember which

Re: does xnViewMP have an error log?

Posted: Sun Mar 24, 2019 8:04 am
by xnview
if you have the problem, please try to find the file problem?

Re: does xnViewMP have an error log?

Posted: Fri Apr 12, 2019 4:58 am
by limar500
xnview wrote:
Sun Mar 24, 2019 8:04 am
if you have the problem, please try to find the file problem?
after a lot of trial and error I found the problem:
when I'm in a thumbnail view - for some videos, the process of creating a thumbnail for that video gets stuck (the process bars gets stuck on %76 or where ever it comes across that file)... the process goes on forever until xnviewmp turns unresponsive and I no choice but to shutdown the process in the "Task manager".

if I delete or move the file from the folder - xnviewmp goes all the way to 100% and everything is fine.
of course if I switch to different view that doesn't require thumbnails there is no problem as well.

the video itself plays find in xnviewmp and in any video player, so I have no indication as to what is wrong with the video file or xnviewmp can't succeed in creating a thumbnail for it.

what can be done?

Re: does xnViewMP have an error log?

Posted: Mon Apr 15, 2019 12:14 pm
by xnview
limar500 wrote:
Fri Apr 12, 2019 4:58 am
what can be done?
Is it possible to send me the video file? You can disable thumbnails for video file

Re: does xnViewMP have an error log?

Posted: Tue Apr 16, 2019 4:34 pm
by limar500
xnview wrote:
Mon Apr 15, 2019 12:14 pm
limar500 wrote:
Fri Apr 12, 2019 4:58 am
what can be done?
Is it possible to send me the video file? You can disable thumbnails for video file
can I disable thumbnail creation for a certain, specific video file?

Re: does xnViewMP have an error log?

Posted: Tue Apr 16, 2019 6:24 pm
by Tehbotol
hi i'm also the one that affected by the bug, and currently in communication with the dev, and the dev is trying to fix it
seems it's related to short duration video that cause xnview mp unable to make the thumbnail

for now what i notice helps is disabling the 4 thumbnails option (uncheck it) in Settings - Thumbnail - Show 4 thumbnails
which should reduce the hang up to minimum (from 3 video i sent to the dev, 2 managed to be browsed without any issue with 1 thumbnails mode)

also if you like maybe just move the video that have issue to another folder first (you can find the problematic video by looking at the xnview browse and find the first one that doesn't have thumbnail) or you can also disable the thumbnails creation for video in the settings

Re: does xnViewMP have an error log?

Posted: Wed Apr 17, 2019 7:27 am
by xnview
limar500 wrote:
Tue Apr 16, 2019 4:34 pm
can I disable thumbnail creation for a certain, specific video file?
you can in settings>Filelist>exclude

Re: does xnViewMP have an error log?

Posted: Fri Apr 19, 2019 3:32 am
by GeF
Tehbotol wrote:
Tue Apr 16, 2019 6:24 pm
hi i'm also the one that affected by the bug, and currently in communication with the dev, and the dev is trying to fix it
seems it's related to short duration video that cause xnview mp unable to make the thumbnail

for now what i notice helps is disabling the 4 thumbnails option (uncheck it) in Settings - Thumbnail - Show 4 thumbnails
which should reduce the hang up to minimum (from 3 video i sent to the dev, 2 managed to be browsed without any issue with 1 thumbnails mode)

also if you like maybe just move the video that have issue to another folder first (you can find the problematic video by looking at the xnview browse and find the first one that doesn't have thumbnail) or you can also disable the thumbnails creation for video in the settings
This fixed my problem, disabling the 4 thumbnails for videos. I've been going nuts because half of my folders would not load correctly and freeze during scanning for no discernable reason.

Thanks

Re: does xnViewMP have an error log?

Posted: Fri Apr 19, 2019 9:22 am
by xnview
GeF wrote:
Fri Apr 19, 2019 3:32 am
This fixed my problem, disabling the 4 thumbnails for videos. I've been going nuts because half of my folders would not load correctly and freeze during scanning for no discernable reason.
please, send me some video files with the problem?

Re: does xnViewMP have an error log?

Posted: Sat Apr 20, 2019 4:43 am
by Tehbotol
also could someone here test this videos and see if it make xnview mp deadlock/hang
since it cause xnview mp to hang on my pc but not on the dev pc

https://drive.google.com/file/d/1S9K5Ko ... sp=sharing
https://drive.google.com/file/d/1O2ODIy ... sp=sharing
https://drive.google.com/file/d/1f1n4ZD ... sp=sharing

please separate the video to 3 folder and try to browse one by one in xnview mp

Re: does xnViewMP have an error log?

Posted: Mon Apr 22, 2019 12:17 pm
by xnview