Page 1 of 1

Assigning Category: slow

Posted: Sun Aug 12, 2018 4:21 pm
by alobo
When a select a bunch of pictures (e.g., 50) to tag them with a common Category,
the system remains unresponsive for a while. As far as I can see, after few seconds
the tags have been assigned, but I find very confusing that once the user selects a
category there is no Apply button and there is no message telling the user to wait while
the category is being assigned to each picture.
Or perhaps I'm doing something wrong...

Re: Assigning Category: slow

Posted: Mon Aug 13, 2018 7:46 am
by xnview
which format? what are your settings in 'Metadata'?

Re: Assigning Category: slow

Posted: Mon Aug 13, 2018 10:47 am
by alobo
This is what I have, perhaps not the best?
https://www.dropbox.com/s/shg6fulmn56vb ... s.JPG?dl=0

Re: Assigning Category: slow

Posted: Tue Aug 14, 2018 9:26 am
by xnview
so category are written in the file itself. But which format of pictures?

Re: Assigning Category: slow

Posted: Tue Aug 14, 2018 2:14 pm
by alobo
xnview wrote:
Tue Aug 14, 2018 9:26 am
so category are written in the file itself. But which format of pictures?
JPG right now, but I will be using RAW and tif as well.

Re: Assigning Category: slow

Posted: Tue Aug 14, 2018 2:32 pm
by xnview
If you select 50 JPG it's slow? do you assign category in the bottom category pane?

Re: Assigning Category: slow

Posted: Tue Aug 14, 2018 3:06 pm
by alobo
xnview wrote:
Tue Aug 14, 2018 2:32 pm
If you select 50 JPG it's slow? do you assign category in the bottom category pane?
Yes, I use this:
https://www.dropbox.com/s/z5g2k1m82vpuq ... s.JPG?dl=0

and the the program is unresponsive for a while.

What bothers me most is the fact that once you click a box there is no an Apply button, it seem the Category is immediately written. It is very easy to click a wrong box, an Apply button would be safer. Also,
you could select several different boxes and then Apply. And get a "Wait..." message or something while the program works.

Re: Assigning Category: slow

Posted: Tue Aug 14, 2018 3:38 pm
by xnview
alobo wrote:
Tue Aug 14, 2018 3:06 pm
What bothers me most is the fact that once you click a box there is no an Apply button, it seem the Category is immediately written. It is very easy to click a wrong box, an Apply button would be safer. Also,
you could select several different boxes and then Apply. And get a "Wait..." message or something while the program works.
the categories are written when you change the image selection.

could you send me one or more file samples that you use?

Re: Assigning Category: slow

Posted: Wed Aug 15, 2018 6:20 pm
by alobo
[/quote]
the categories are written when you change the image selection.

could you send me one or more file samples that you use?
[/quote]

I had that impression: nothing happens until you try to select another photo. Anyway, it's very confusing, much better having
an apply button.

Sent a link privately.
Agus

Re: Assigning Category: slow

Posted: Tue Aug 28, 2018 3:45 pm
by xnview
i've tried with 50 copies of your picture file, i assign to a category, and writting take 1-2 sec. Could you try?

Re: Assigning Category: slow

Posted: Fri Aug 31, 2018 3:55 pm
by alobo
xnview wrote:
Tue Aug 28, 2018 3:45 pm
i've tried with 50 copies of your picture file, i assign to a category, and writing take 1-2 sec. Could you try?
It is a matter of the external drive: I tried with 64 copies on the local hard drive and tagging with a test sub-subcategory took no time.
The same test done with the folder in the external drive took 36 seconds.
For 359 real pictures (tagged with a sub-subcategory within Sites) on the external disk, it took 186 s
As using external drives is common, an "Apply" button and and a "Wait..." message would be appropriate.

Problem clarified.

Re: Assigning Category: slow

Posted: Sat Sep 01, 2018 2:54 pm
by xnview
what is your external drive?

Re: Assigning Category: slow

Posted: Sun Sep 02, 2018 4:39 pm
by alobo
xnview wrote:
Sat Sep 01, 2018 2:54 pm
what is your external drive?
LaCie Rugged 1 Tb
It works fine at reasonable speed with other programs.
Agus

Re: Assigning Category: slow

Posted: Tue Sep 11, 2018 11:15 am
by xnview
To update categories, XnView needs to re-write the full file. So on slower drive (not ssd), i have 8 seconds for 100 files

Re: Assigning Category: slow

Posted: Sat Sep 15, 2018 7:17 am
by alobo
xnview wrote:
Tue Sep 11, 2018 11:15 am
To update categories, XnView needs to re-write the full file. So on slower drive (not ssd), i have 8 seconds for 100 files
This type of LaCie external disks (and equivalent) is very common, not sure we can call the "slow". Anyway, I do not argue on this.
I'm just asking for an "Apply" button and a "Wait..." message. Even with 8 sec, with no Apply button and message the user is likely to start clicking here and there and eventually closing the program.