Images not displaying?

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Xnout!
Posts: 29
Joined: Wed May 24, 2017 2:18 am

Images not displaying?

Postby Xnout! » Fri Jun 09, 2017 10:19 pm

I have some images I downloaded from the internet that do not display in XnView.
They show an image on the thumbnail but not in the previewer or fullscreen.

If I open them in another program, like FastStone Image Viewer, they display beyond just the thumbnail.
If I convert them in FastStone they work fine in XnView (XnView's convert function does not work on these files, individual
or batch).

The files are JPG.

Any thoughts on why this type of thing happens. It's not a big deal, I can convert them (although, it's lame to have to rely on
another program to fix). I've only seen it from one or two sites.
Possible embedded security display inhibition or damaged header/file data in download process?

User avatar
xnview
Author of XnView
Posts: 28043
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Images not displaying?

Postby xnview » Sat Jun 10, 2017 10:36 am

do you have tried to enable option>Read-Write>ignore read errors?
Pierre.

Xnout!
Posts: 29
Joined: Wed May 24, 2017 2:18 am

Re: Images not displaying?

Postby Xnout! » Sat Jun 10, 2017 11:43 am

Settings > Format > Read > ignore read errors does not help.

Even if it did, it sounds like it would just hide the problem. I would want to be aware of it and then be able to proceed in converting
to same specs to correct. To expand on earlier comments, XnView convert does not work on them, but the batch convert at least shows up on
right-click menu and attempts to execute but throws up an "open error" message. The individual/specific right-click convert is
faded out and can't be attempted

cday
XnThusiast
Posts: 1561
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Images not displaying?

Postby cday » Sat Jun 10, 2017 12:02 pm

Xnout! wrote:Settings > Format > Read > ignore read errors does not help.

Even if it did, it sounds like it would just hide the problem. I would want to be aware of it and then be able to proceed in converting
to same specs to correct. To expand on earlier comments, XnView convert does not work on them, but the batch convert at least shows up on
right-click menu and attempts to execute but throws up an "open error" message. The individual/specific right-click convert is
faded out and can't be attempted

XnView software for some reason seems less tolerant of slightly malformed files, could you upload an example JPEG (in a ZIP or similar archive to ensure that the file isn't altered in any way) for examination?

Xnout!
Posts: 29
Joined: Wed May 24, 2017 2:18 am

Re: Images not displaying?

Postby Xnout! » Sat Jun 10, 2017 8:57 pm

cday wrote:XnView software for some reason seems less tolerant of slightly malformed files, could you upload an example JPEG (in a ZIP or similar archive to ensure that the file isn't altered in any way) for examination?

Thanks. I tested it out by posting it to imugr and then downloading a copy. But somewhere in the download/copy process, it seems to get
corrected and that downloaded copy works fine in XnView. If you make a copy normally in explorer or XnView, that copy still fails to
show correctly. :?

cday
XnThusiast
Posts: 1561
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Images not displaying?

Postby cday » Sat Jun 10, 2017 9:27 pm

Xnout! wrote:
cday wrote:XnView software for some reason seems less tolerant of slightly malformed files, could you upload an example JPEG (in a ZIP or similar archive to ensure that the file isn't altered in any way) for examination?

Thanks. I tested it out by posting it to imugr and then downloading a copy. But somewhere in the download/copy process, it seems to get
corrected and that downloaded copy works fine in XnView. If you make a copy normally in explorer or XnView, that copy still fails to
show correctly. :?

But do you have an example file that you could upload in a ZIP to the forum so that [people more knowledgeable than me] can examine it?

Xnout!
Posts: 29
Joined: Wed May 24, 2017 2:18 am

Re: Images not displaying?

Postby Xnout! » Sat Jun 10, 2017 9:40 pm

I could do that, but is there a way to open a ticket here? There isn't an official support, right (open tickets and such)?
Or, email to XnView direct?


Return to “MP - General Support”

Who is online

Users browsing this forum: No registered users and 2 guests